forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From SteveOdlind <steve.odl...@btinternet.com>
Subject Re: PDF not working correctly in deployed WAR file on Tomcat
Date Wed, 06 Feb 2008 10:38:24 GMT

> Also see the demo in the forrest seed sample site. Try building
> and deploying its WAR. There are some general issues with
> placement of source images.
> http://issues.apache.org/jira/browse/FOR-635

I will try to deploy the seed site's WAR file.

I don't think my problem is related to FOR-635 as images display fine in
PDFs served by Jetty ('forrest run').


> Steve Odlind wrote:
> >
> > Hello all,
> >
> > I am hoping you can help me with a Forrest/Tomcat problem.
> >
> > I am running Forrest 0.8, and am trying to deploy a WAR file on Tomcat.
> > The problem is that PDFs get stripped of their images, and only text is
> > displayed.
> >
> > I can't get PDFs to display at all by deploying the Webapp on Tomcat. I
> > have read http://issues.apache.org/jira/browse/FOR-735, and followed the
> > advice, but cannot get PDFs to be displayed at all.

> FOR-735 was closed prior to 0.8 release, so that should be fine.

> > So, is there an update to this already-known-problem? I am half of the
> way
> > there with WAR files, I just need to get the images displayed as well.

> You don't say, but have you followed the FAQ:
> http://forrest.apache.org/docs/faq.html#pdf_images
> ... but i suppose you would have or images would
> also be missing in 'forrest run' mode.

Yes, I have followed that FAQ. Images are not missing in 'forrest run' mode.



-- 
View this message in context: http://www.nabble.com/PDF-not-working-correctly-in-deployed-WAR-file-on-Tomcat-tp15295911p15306463.html
Sent from the Apache Forrest - Users mailing list archive at Nabble.com.


Mime
View raw message