forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Philip Aston <phil...@mail.com>
Subject Re: <all_site/> fails with "(Is a directory)" broken link?
Date Wed, 23 Jan 2008 11:08:07 GMT
Thorsten Scherler wrote:
> On Tue, 2008-01-22 at 19:03 +0000, Philip Aston wrote:
> ...
>> I've applied it to 0.8, but it doesn't address the whole site issue I
>> reported last week.
>>
>> My problem has a slightly different signature, e.g.
>> "/home/philipa/workspace/grinder-docs/src/documentation (Is a
>> directory)" instead of a moan about the permissions, but is definitely
>> LM related.
> 
> Actually AFAIR the signature may differ from the OS you use. The report
> was for windows and you are on linux, right?

Yes, I'm on linux.

>> I get this with wholesite, as well as with a custom aggregation I'm
>> using. The custom aggregation transformation work if I specify them as e.g.
>>
>>   <map:transform src="{forrest:forrest.stylesheets}/site-to-book.xsl" />
>>
>> rather than
>>
>>   <map:transform src="{lm:site-to-book.xsl}" />
>>
>> Any clues?
> 
> the above should read:
> <map:transform src="{lm:transform.site.book}" />

Thanks Thorsten, with that change, my custom aggregation works with or
without the patch.

However,

  <all label="All documentation" tab="project">
    <whole_site_html label="Wholesite HTML" href="wholesite.html"/>
    <whole_site_pdf label="Wholesite PDF" href="wholesite.pdf"/>
  </all>

continues to fail with or without the patch.

- Phil

Mime
View raw message