forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dieter Schicker <dil...@dilino.org>
Subject Re: wholesite.pdf doesn't work [SOLVED]
Date Thu, 03 Jan 2008 20:23:51 GMT
Hi,

I solved my problem now, just in case someone is interested here is how
I did it:

The "No flow in page-sequence" error was raised because in my site.xml I
referenced documents that did not already exist.

So far so good.

Then I got the following error:

internal-destination or external-destination must be specified in basic-link

That was because I had empty urls in some a tags (e.g. <a href="">).

I changed that, too. Now it works and I'm happy! ;-)

Forrest rocks.

Cheers
Dieter



Dieter Schicker wrote:
> Hi there,
>
> I'm new to forrest - so please forgive me if I'm asking stupid questions.
>
> I have a problem with the "wholesite.pdf" functionality. My site.xml
> looks like
>
> ...
> <about label="Allgemein">
>   <index label="Was ist ZIMnet?" href="index.html" description=""/>
>   <whole_site_pdf label="Whole Site PDF" href="wholesite.pdf"/>
> </about>
> ...
>
> When I click on it I get
>
>
>   Internal Server Error
>
> Message: null
>
> Description: No details available.
>
> Sender: org.apache.cocoon.servlet.CocoonServlet
>
> Source: Cocoon Servlet
>
> cause
>
> No flow in page-sequence
>
> Request URI
>
> wholesite.pdf
>
> request-uri
>
> /zimnet/wholesite.pdf
>
> Apache Cocoon 2.2.0-dev <http://cocoon.apache.org/>
>
>
> Any ideas? Shall I also post my forrest logs?
>
> TIA
> Dieter
>
>
>
>   


Mime
View raw message