forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stuart Yeates <stuart.yea...@oucs.ox.ac.uk>
Subject Re: forreestbot mail not being sent
Date Thu, 29 Nov 2007 11:05:52 GMT
David Crossley wrote:
> Stuart Yeates wrote:
>> We've got a problem in which mail is not sent from forrestbot when a
>> run in completed. The build and upload work fine. The build file has
>> the following properties:
>>
>>  <property name="notify.email.host" value="smtp.ox.ac.uk"/>
>>  <property name="notify.email.to" value="stuart.yeates@oucs.ox.ac.uk"/>
>>  <property name="notify.administrator" value="Stuart Yeates"/>
>>
>> The machine can connect to smtp.ox.ac.uk on port 25 via telnet, so
>> that's not the issue.
>>
>> The output (stdout) is:
>>
>> notify.email:
>> Override ignored for property NOW
>> Override ignored for property DSTAMP
>> Override ignored for property TSTAMP
>> Override ignored for property TODAY
>> Using plain mail
>> Sending email: ForrestBot build for simalbot succeeded
>> From Forrestbot
>> ReplyTo []
>> To [stuart.yeates@oucs.ox.ac.uk]
>> Cc []
>> Bcc []
>> Failed to send email
>>
>> Can anyone see what I'm doing wrong? Does anyone know how to turn
>> debugging on in org.apache.commons.net (which appears to be where
>> things are going wrong)?
> 
> Do you have the "notify.on.failure" etc. set in your forrestbot
> descriptor? I suppose yes, or it wouldn't be trying to send the mail.
> 
> Our docs say that some mailers need "notify.email.from".
> 
> http://forrest.apache.org/tools/forrestbot.html#notify.email
> 
> The forrestbot on our zone has "notify.email.host" as "localhost".
> 
> Our descriptors are in our SVN if that helps for examples:
> http://forrest.apache.org/zone.html
> 
> Try a test to ensure that you can send mail direct from the
> command-line on your server, as the user which runs forrestbot.
> 
> That is all that i can think of for now.

I tried adding these properties, to no avail.

I eventually bit the bullet and installed an MTA (postfix) on the
machine and changed the  notify.email.host to localhost. Everything
worked instantly.

The two smtp hosts I tried to connect to are both quite aggressive
in anti-spam measures, so maybe the roots lie there.

cheers
stuart
-- 
OSS Watch: http://www.oss-watch.ac.uk/

Mime
View raw message