Maybe if you start using forrest, it would be better to start with the 0.8 release candidate? You can find it here  http://people.apache.org/~crossley/forrest-08-rc1/

This version should (soon) be final and I think you can start your new developments using it :-)



On 4/13/07, Scott Brown <doolagarl2002@yahoo.com.au> wrote:
When I try to run forrest 0.7, I get the following error message:

 Could not find component for role: [org.apache.cocoon.components.modules.input.InputModule/lm] (Key='org.apache.cocoon.components.modules.input.InputModule/lm')

How do I fix this?

When I googled for this bug, I found the suggestion to add
org.apache.forrest.plugin.input.projectInfo to the 
project.required.plugins line in forrest.properties, but when
I tried this it didn't have any effect.

Send instant messages to your online friends http://au.messenger.yahoo.com