forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ross Gardler <rgard...@apache.org>
Subject Re: How can I start using Forrest?
Date Wed, 11 Apr 2007 10:55:39 GMT
schumarer schumarer wrote:
> and still the same problem.
> 
>         java.lang.UnsupportedClassVersionError:
>         org/apache/forrest/log/ForrestLogTargetFactory (Unsupported
>         major.minor version 50.0)

I'm not sure which version of Forrest is giving you this error. I know 
you have SVN head so lets work with that (we are actually in a code 
freeze and testing the release package right now, so you may as well 
stick with it).

So, lets start from the beginning again. Do the following:

set FORREST_HOME=path/to/forrest-0.8/checkout
cd %FORREST_HOME%\main
build.bat clean
build.bat

cd some/temp/dir
forrest seed-samples
forrest

> Do you know why and when this error occurs ? If I understand when, maybe 
> I would be able to hack forrest at a later time in the process of 
> building the site ?

All I know for certain is that this is an issue with your environment, 
not with Forrest itself. I know that Forrest runs perfectly well on 
windows with:

java version " 1.5.0_11"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_11-b03)
Java HotSpot(TM) Client VM (build 1.5.0_11-b03, mixed mode, sharing)

(I have the exact same setup locally on Windows XP Pro)

Forrest will give you more clues as to where the problem occurs in its 
logs. These can be found in build/webapp/logs within your content object 
directory.

Ross

Mime
View raw message