forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brolin Empey" <brolin.em...@gmail.com>
Subject "Could not find component for role" after upgrading to 0.8
Date Mon, 23 Apr 2007 21:05:31 GMT
Hello,

I wanted to be able to use Forrest 0.8 to successfully build a site
that worked with Forrest 0.7.

I started this project last week, so I may have forgotten some of the
things I did.

I changed $FORREST_HOME to point to Forrest 0.8 instead of 0.7. "type
forrest" in bash confirms that "forrest" runs Forrest 0.8.

I then tried to follow the directions in
http://forrest.apache.org/docs_0_80/upgrading_08.html .  I copied
locationmap.xml .  I did not know what to do about the "Forrest
configuration simplification" step. I ran "forrest clean-work".

When I run "forrest" I get this line after the Cocoon header block:

X [0]                                     linkmap.html  BROKEN: Could
not find component for role:
[org.apache.cocoon.components.modules.input.InputModule/project]
(Key='org.apache.cocoon.components.modules.input.InputModule/project')

The build is aborted after this failure.

What can I do?

Thanks,
Brolin

PS: See my previous posts for my system configuration.

Mime
View raw message