forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Crossley <cross...@apache.org>
Subject Re: Forrest error message "Could not find component for role"
Date Fri, 13 Apr 2007 09:31:49 GMT
Ross Gardler wrote:
> Scott Brown wrote:
> >When I try to run forrest 0.7, I get the following error message:
> >
> > Could not find component for role: 
> >[org.apache.cocoon.components.modules.input.InputModule/lm] 
> >(Key=?org.apache.cocoon.components.modules.input.InputModule/lm?)
> 
> This is a known issue.
> 
> >How do I fix this?
> >
> >When I googled for this bug, I found the suggestion to add
> >
> >org.apache.forrest.plugin.input.projectInfo to the 
> >project.required.plugins line in forrest.properties, but when
> >I tried this it didn't have any effect.
> 
> I think you misread the post (or the post was incorrect). The solution 
> is to add a plugin version number to that line:
> 
> org.apache.forrest.plugin.input.projectInfo-0.1

Yes, see the FAQ.
http://forrest.apache.org/faq.html
use your browser's "find in page" for "InputModule"
voila ...
http://forrest.apache.org/faq.html#older-plugins

> Or, as others have pointed out you could download the 0.8 release 
> candidate currently in testing and let us know if it works for you.
> 
> If all goes well this will be the current release very soon.

Please do not encourage users to use stuff that
is for developers. By all means encourage people
to move over to the dev@ list where it all happens.

For explantion of that important aspect of our open
development practice.
http://www.apache.org/dev/release.html#what
especially paragraph #2.

-David

Mime
View raw message