forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Crossley <>
Subject Re: Could not find component for role (reloaded)
Date Thu, 22 Feb 2007 01:05:36 GMT
On Sun, Jan 28, 2007 Olivier Wehner wrote:
> Hi there,
> i just run into a problem that is similar to the one mentioned in the 
> faqs at
> Whenever i call "forrest run" or "forrest" in FORREST_HOME/site-author i 
> will get errors that condense to:
> Could not find component for role: 
> [org.apache.cocoon.components.modules.input.InputModule/lm] 
> (Key='org.apache.cocoon.components.modules.input.InputModule/lm')
> A well known problem you might say, but i followed the instructions 
> given in
> I even recreated the forrest installation three times, making sure not 
> to use symlinks and eventually added the "-0.1" version specifier in all 
> files i could find. Still i neither get the dynamic 
> nor the generated documentation.
> Note that after the "clean" build described in the mail above, the 
> in the plugin directories will contain 
> "org.apache.forrest.plugin.input.projectInfo" (without version 
> speciefier), even though i adapted 
> FORREST_HOME/plugins/pluginTemplate/
> Most probably i forgot the obvious thing to do; in this case forgive my 
> ignorance.

Why are you editing that file? As the directory names imply
that is just a template for creating new plugins.

You need to edit the in your own site's space. 
mkdir new-directory
cd new-diectory
forrest seed

Above you seem to imply that you are having troubles
with the 0.7 release's Forrest documentation. In this case
you need to edit your $FORREST_HOME/site-author/


View raw message