forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Olivier Wehner <oweh...@gmx.net>
Subject Could not find component for role (reloaded)
Date Sun, 28 Jan 2007 17:57:56 GMT
Hi there,

i just run into a problem that is similar to the one mentioned in the 
faqs at http://forrest.apache.org/docs_0_80/faq.html#older-plugins.

Whenever i call "forrest run" or "forrest" in FORREST_HOME/site-author i 
will get errors that condense to:

Could not find component for role: 
[org.apache.cocoon.components.modules.input.InputModule/lm] 
(Key='org.apache.cocoon.components.modules.input.InputModule/lm')

A well known problem you might say, but i followed the instructions 
given in

http://mail-archives.apache.org/mod_mbox/forrest-user/200511.mbox/%3c20051112071951.GA8762@igg.indexgeo.com.au%3e

I even recreated the forrest installation three times, making sure not 
to use symlinks and eventually added the "-0.1" version specifier in all 
forrest.properties files i could find. Still i neither get the dynamic 
nor the generated documentation.

Note that after the "clean" build described in the mail above, the 
forrest.properties in the plugin directories will contain 
"org.apache.forrest.plugin.input.projectInfo" (without version 
speciefier), even though i adapted 
FORREST_HOME/plugins/pluginTemplate/forrest.properties

Most probably i forgot the obvious thing to do; in this case forgive my 
ignorance.

Best regards,

Olivier

-- 

olivier wehner
      bruxelles


Mime
View raw message