forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gav...." <brightoncomput...@brightontown.com.au>
Subject RE: SVG images not displayed in PDFs using Forrest version 0.8
Date Tue, 09 Jan 2007 11:08:35 GMT
Hi Steve,


> -----Original Message-----
> From: Steve Odlind [mailto:Steve.Odlind@TouchClarity.com]
> Sent: Tuesday, 9 January 2007 6:58 PM
> To: user@forrest.apache.org
> Subject: RE: SVG images not displayed in PDFs using Forrest version 0.8
> 
> Hi,
> 
> PNGs display fine in html and PDF (as long as they are in the
> resources/images directory).
> 
> SVG images are not displayed in PDFs, regardless of the directory they
> are in. I have tried resources/images and xdocs/images.

Well, Having tested this again using
http://localhost:8888/samples/linking.pdf

It seems you are correct, this wasn't the case before, I remember some of
The images showing, now none of them are, not even png images appear for me
On the above page. This is using skins 0.8-dev with only pdf plugin.

Perhaps something has changed to make FOR-635 even worse of an issue than
It once was. This is a quick investigation, I'll look into it more.

Gav...

> 
> Thanks.
> 
> -----Original Message-----
> From: Gav.... [mailto:brightoncomputers@brightontown.com.au]
> Sent: 08 January 2007 22:47
> To: user@forrest.apache.org
> Subject: RE: SVG images not displayed in PDFs using Forrest version 0.8
> 
> Hi Steve,
> 
> ________________________________________
> From: Steve Odlind [mailto:Steve.Odlind@TouchClarity.com]
> Sent: Tuesday, 9 January 2007 2:10 AM
> To: user@forrest.apache.org
> Subject: SVG images not displayed in PDFs using Forrest version 0.8
> 
> Hi all,
> 
> I am hoping that someone can help me with an SVG-related problem.
> 
> Previously, using version 0.7 of Forrest, SVG images would be displayed
> fine
> in PDFs. However, I recently downloaded version 0.8 (SVN 494119), and
> now
> find that the same SVG images are no longer displayed in PDFs, while an
> equivalent PNG image will be displayed in the same PDF. The images are
> located in the resources/images directory, so I think I have placed them
> in
> the correct location.
> 
> Do I need to make some configuration change, or can SVG images no longer
> be
> used in PDFs generated by version 0.8?
> 
> Kind regards,
> 
> Steve
> 
> 
> There are a few issues regarding PDFs and images.
> 
> https://issues.apache.org/jira/browse/FOR-635
> https://issues.apache.org/jira/browse/FOR-413
> 
> Either or none of these may be related, in fact the first one, FOR-635
> Seems almost opposite to your problem. Yours can not find them in the
> Resources directory whereas the above issue is fine with that directory
> But can not find them in xdocs/images. What happens for you when you put
> Them back there out of interest.
> 
> As there are issues open, they will be worked on when devs have the
> time.
> 
> Gav...
> 
> 
> 
> --
> No virus found in this incoming message.
> Checked by AVG Free Edition.
> Version: 7.1.410 / Virus Database: 268.16.7/620 - Release Date: 1/8/2007


Mime
View raw message