forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "C. Grobmeier" <grobme...@possessed.de>
Subject Re: [Dispatcher] Locate theme
Date Fri, 27 Oct 2006 19:14:49 GMT
Hi all,
i have found my problem.
$PROJECT_HOME/documentation/resources/structurer/url/cg.fv
this worked- but i must have it named pelt.fv and i must have it in my 
forrest.properties.xml as:

   <property name="dispatcher.theme" value="pelt"/>

I don't know why this is like this, but in my case everything else 
doesn't work. I haven't tried out if value="common" and a copy of 
common.fv works. I will do this tomorrow.

If you can explain that to me- i am eager to hear :-)
Thanks for your help,
Chris

Cyriaque Dupoirieux wrote:
> le 27/10/2006 17:04 C. Grobmeier a écrit :
>> hm, i didn't get the correct theme. meanwhile i am quite sure it's 
>> some kind of problem with my locationmap- can you help me?
>>
>> Regards,
>> Chris
>>
>> C. Grobmeier wrote:
>>> Hi,
>>> found a mail from Gav.., he wrote:
>>>
>>> "So it seems I needed to enable :-
>>>
>>> project.content-dir=src/documentation
>>> project.xdocs-dir=${project.content-dir}/content/xdocs
>>> project.resources-dir=${project.content-dir}/resources
>>> "
>>>
>>> thats also true for me- thats very strange, worth an entry in the docs?
>>> Regards,
>>> Chris
>>>
>>> C. Grobmeier wrote:
>>>> Hi,
>>>>
>>>> i read:
>>>> http://forrest.apache.org/pluginDocs/plugins_0_80/org.apache.forrest.plugin.internal.dispatcher/how/howto-dispatcher-quickstart.html

>>>>
>>>>
>>>> There is:
>>>> "Copy THEMER_PLUGIN/themes/pelt.fv into your project at 
>>>> ${themer.project.dir}/pelt.fv"
>>>>
>>>> So i copied pelt.fv from:
>>>> $FORREST_DIR/whiteboard/plugins/org.apache...dispatcher/src/doc.../resources/themes/pelt.fv

>>>>
>>>>
>>>> to:
>>>> $MYPROJECT/src/doc../resources/themes/pelt.fv
> Try to copy it in 
> $PROJECT_HOME/documentation/resources/structurer/url/pelt.fv
>>>>
>>>> Then i renamed it to cg.fv. In forrest.properties i changed this lines:
>>>> project.theme-extension=.fv
>>>> project.theme=cg
>>>>
> So $PROJECT_HOME/documentation/resources/structurer/url/cg.fv ...
> 
> And tell me,
> 
> Salutations,
> Cyriaque,
>>>>
>>>> That Forrest can find my theme, i added:
>>>>      <match pattern="themer.project.dir">          <location 
>>>> src="{properties:resources}/themes" />      </match>
>>>> to the locationmap.xml.
>>>>
>>>> Then i commented out search-input, like the how-to said, restarted 
>>>> forrest and wanted to see the new theme with no searchbox. The new 
>>>> theme is there, but i have no change at my searchbox. Its still there.
>>>>
>>>> I tried to change
>>>> $FORREST_DIR/whiteboard/plugins/org.apache...dispatcher/src/doc.../resources/themes/pelt.fv

>>>>
>>>> to see if forrest is looking here for the theme. But no affect, 
>>>> still the box is there.
>>>>
>>>> Does somebody of you have an idea what theme i am currently using? I 
>>>> think i miss something, but i don't know what. It looks like forrest 
>>>> is taking another .fv file than i expect.
>>>>
>>>> regards,
>>>> Chris
>>>>
>>>>
>>>>
>>>>
>>>>
>>>
>>
>>


Mime
View raw message