forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andreas Zocher <andreas.zoc...@students.unibe.ch>
Subject Re: Does Forrest 07 run on libgcj?
Date Tue, 04 Jul 2006 17:59:34 GMT
libgcj is the GNU Java runtime and java-gcj-compat is a set of wrappers
and links (and eclipse is the Java compiler) that comes with Fedora
Linux. JPackage is Project, that offers different Java environments.

The JPackage Run Time Packages for GCJ (JRE) doesn't include a
tools.jar-like class. "JPackage development scripts for GCJ" (SDK)
contains these tools.

So I installed java-1.4.2-gcj-compat-devel-... and the forrest is
turning green on Fedora Linux.

Andreas



Am Dienstag, den 04.07.2006, 16:48 +0100 schrieb Ross Gardler:
> Andreas Zocher wrote:
> > Hi,
> > 
> > i use the GCJ runtime libgcj on a fedora 5 maschine and i would like to
> > run forrest 0.7.
> > 
> > Without JRE Forrest says:
> > ---
> > $ forrest -projecthelp
> > Apache Forrest.  Run 'forrest -projecthelp' to list options
> > 
> > Unable to locate tools.jar. Expected to find it
> > in /usr/lib/jvm/java-1.4.2-gcj-1.4.2.0/lib/tools.jar
> > ---
> > 
> > Do I have to replace libgcj by SUN's JRE 1.5?
> 
> I have no idea about libjcj specifically since I don't know what it is. 
> I can tell you that you do not need 1.4, I can also tell you that 
> tools.jar has been a standard part of the java distribution since the 
> very early days.
> 
> I'm guessing that libgcj is supposed to be a Java Virtual Machine, if 
> this is correct then it must provide the classes that are in tools.jar 
> (assuming it is complete). You ay need to adjust the classpath set in 
> the ant build files to accomodate your setup.
> 
> If you get this working please provide some documentation for us to add 
> for those coming after you.
> 
> Ross


Mime
View raw message