forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Web Maestro Clay <the.webmaes...@gmail.com>
Subject Forrestbot + SVN = mixed line-endings in HTML
Date Thu, 02 Mar 2006 16:46:47 GMT
We have a new problem using forrestbot. Part of this could be my own  
settings, but I am assured by Jeremias that this isn't completely the  
case. Please see below.

> On 02.03.2006 00:12:42 Clay Leeds wrote:
>> On Mar 1, 2006, at 1:28 PM, Jeremias Maerki wrote:
>>> Wonderful. Just what I need. Different platforms, different line
>>> endings, no SVN properties set. And if I want to manually set  
>>> them, SVN
>>> complains about mixed line endings in HTML files. Clay, would you  
>>> mind
>>> asking the Forrest people how they deal with that or how we're  
>>> supposed to deal
>>> with this? I'm not very amused to process each file separately
>>> until I have consistent line-endings and the right SVN properties  
>>> and the
>>> next Forrest run might even take everything apart again. I liked  
>>> the scp
>>> approach better. Sigh.
>>
>> My bad... I don't have my SVN settings correct. I need to set my
>> svn:eol-style property to 'native' & then this shouldn't be a
>> problem. Sorry for the grief!
>>
>> I've made the change locally. I need to also do the same for my other
>> projects.
>
> Part of that may be due to your SVN settings, but I got mixed line
> endings in HTML files generated by Forrest. I haven't checked, yet,  
> why
> this happens but that probably doesn't happen because of your SVN
> settings.
>
> Jeremias Maerki

Please advise.

Clay Leeds
the.webmaestro@gmail.com

My religion is simple. My religion is kindness.
-- HH Dalai Lama of Tibet




Mime
View raw message