forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <lars.bjer...@fsb.se>
Subject SV: SV: UnknownHostException
Date Fri, 03 Mar 2006 06:53:09 GMT
There is another ant on the system but when running forrest I can see:
.....
C:\forrest\sdfii>rem ----- set the ant file to use --------------------------------------

C:\forrest\sdfii>set ANTFILE=C:\apache-forrest-0.7\main\forrest.build.xml 
C:\forrest\sdfii>rem ----- Save old ANT_HOME --------------------------------------------

C:\forrest\sdfii>set OLD_ANT_HOME=C:\apache-ant-1.6.2\dist 
C:\forrest\sdfii>set ANT_HOME=C:\apache-forrest-0.7\tools\ant 
C:\forrest\sdfii>rem ----- Save and set CLASSPATH --------------------------------------------

C:\forrest\sdfii>set OLD_CLASSPATH= 
C:\forrest\sdfii>set CLASSPATH=
.....
which seems to indicate that it´s the right ant that is in use.
Lars


-----Ursprungligt meddelande-----
Från: David Crossley [mailto:crossley@apache.org] 
Skickat: den 3 mars 2006 04:00
Till: user@forrest.apache.org
Ämne: Re: SV: UnknownHostException

lars.bjerges@fsb.se wrote:
> I finally manged to bypass the problem after substituting the DOCTYPE in skinconf.xml:
> <!DOCTYPE skinconfig PUBLIC "-//APACHE//DTD Skin Configuration V0.7-1//EN" "http://forrest.apache.org/dtd/skinconfig-v07-1.dtd">
> 
> with
> 
> <!DOCTYPE skinconfig PUBLIC "-//APACHE//DTD Skin Configuration V0.7-1//EN" "C:\apache-forrest-0.7\main\webapp\resources\schema\dtd/skinconfig-v07-1.dtd">
> 
> That is, pointing to a local resource. It seems that somehow the xml-catalog does not
really do its job here?
> I am behind a firewall and I have set the proxy properties which makes it even more curious.

It is a sure sign that the Catalog Entity Resolver
is not working for you. See below.

Lars Bjerges wrote:
> 
> Hi all.
> 
> I just ran into a frustrating problem when trying to do a "forrest war" (or webapp) generation.
This is forrest 0.7.
>
> When the skinconf.xml file is to be processed I get:
> 
> load-project-props:
> 
> Processing C:\forrest\sdfii\src\documentation\skinconf.xml to C:\forrest\sdfii\build\tmp\no-doctype-project-skinconf.xml
> 
> Loading stylesheet C:\apache-forrest-0.7\main\webapp\resources\stylesheets\strip-doctype.xsl
> 
> Warning: catalogpath listing external catalogs will be ignored: Fatal Error! java.net.UnknownHostException:
forrest.apache.org Cause: java.net.UnknownHostException: forrest.apache.org

There are two error messages there.
The first one is a warning that the entity resolver isn't
working. Because of that Ant is trying to get the DTD
directly from the Forrest website. For some reason it cannot
reach it.

Do you have another version of Apache Ant on your system?

> Failed to process C:\forrest\sdfii\src\documentation\skinconf.xml
> 
> BUILD FAILED
> 
> C:\apache-forrest-0.7\main\forrest.build.xml:277: Fatal error during transformation
> 
> This does not happen when I do a "forrest site" or "forrest run".
> 
> I am behind a fire-wall but has set up the proxy-properties in my (project) forrest.properties
(i.e. proxy.host, proxy.port, proxy.user and proxy.password)

Is there network activity looking for the DTDs when
you do  'forrest run' or 'forrest site'?
I use ngrep.sf.net
[localhost]$ sudo ngrep dtd

> Furthermore I was under the impression that forrest uses local DTD/Schemas (via XML catalogue)
and I tried to increase the verbosity (to 10) but nothing changed.

It does. I reckon that the "verbosity" setting only
has effect when it is "Forrest" doing the processing.
This 'forrest war' is Ant doing it.

> I also checked the log4j.xml and tried to enable the ConsoleAppender but did  not get
any output at all.
> 
> 
> I would like to get rid of the Warning message: "catalogpath listing external catalogs
will be ignored" that I really don?t understand but have a feeling that it might be a cause
of the problem.

It is. The message comes from Ant.

> Has anyone seen this type of problem before?

Yes. However, it happens in different circumstances.
I thought that we had fixed all of the issues.

-David

Mime
View raw message