forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Clay Leeds <webmaes...@mac.com>
Subject Re: Forrestbot help
Date Fri, 24 Feb 2006 15:56:55 GMT
On Feb 24, 2006, at 2:09 AM, David Crossley wrote:
> I solved it. The "password" that you are prompted for
> is not the "passphrase" for your ssh key, but it is
> the user login password at the *remote* machine.

The passphrase for my ssh key is just the [enter] key (I tried using  
the default and changing it to my password for user@host before I  
asked for help but it didn't help). If I enter a password, it's  
always the one for the remote host.

I just tried one more thing. I modified deploy.settings (located  
at ../site/) to include a value for deploy.scp.password, and it  
didn't help:

<project>
	<property name="deploy.scp.user" value="clay"/>
	<property name="deploy.scp.keyfile" value="/Users/clay/.ssh"/>
	<property name="deploy.scp.passphrase" value="zxaxs"/>
</project>

and it didn't pause for input this time. I also tried with:

<project>
	<property name="deploy.scp.user" value="clay"/>
	<property name="deploy.scp.keyfile" value="/Users/clay/.ssh"/>
	<property name="deploy.scp.password" value="zxaxs"/>
</project>

and this time it did pause. Then I entered my pw for user@host, and  
it BUILD FAILED.

> The Forrestbot deploy.scp workstage only uses the
> "password" method. The allowed parameters are defined
> http://forrest.apache.org/tools/forrestbot.html#deploy.scp
>
> The forrestbot should be enhanced at
> tools/forrestbot/core/deploy.xml line 66
> to take advantage of the "keyfile" parameter
> of the "scp" Ant task.
>
> http://ant.apache.org/manual/OptionalTasks/scp.html
>
> -David


Clay Leeds
webmaestro@mac.com

My religion is simple. My religion is kindness.
-- HH Dalai Lama of Tibet




Mime
View raw message