forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Williams <william...@gmail.com>
Subject Re: Forrest Windows Service (in Tomcat): Plugins don't work
Date Wed, 15 Feb 2006 11:50:04 GMT
On 2/15/06, Johannes Schaefer <johannes.schaefer@uidesign.de> wrote:
> Johannes Schaefer wrote:
> > Hi!
> >
> > I resolved trying 'forrest webapp' to get forrest running as a
> > Windows service and running it in tomcat.
> >
> > This is not a well-documented feature, e.g. I'm not sure about the
> > differences between 'webapp', webapp-local' and 'war' options.
> >
> > To get it running, using forrest-0.7-377981:
> >
> > 1. Adapt web.xml, see http://tinyurl.com/cn5ep (Mail archive)
> >
> >   Now Forrest runs and produces some output but *not a single*
> >   plugin works:
> >     output.pdf, input.sdocbook, input.excel, input.projectInfo
> >
> > 2. Copy Forrest/build/plugins into the webapp dir and change
> >    the plugins entry in
> >      in webapps\my-project\WEB-INF\xconf\forrest-core.xconf
> >    to
> >      <plugins>@context.home@/plugins</plugins>
> >    as described in http://issues.apache.org/jira/browse/FOR-403
> >    (which is marked as fixed).
> >
> > This seems to work using Forrest-0.7-latest.
> >
> > I also tried Forrest-HEAD (r377981) but 'forrest webapp' seems
> > to be broken: it looks for tab2menu.xsl instead for the renamed
> > tab-to-menu.xsl; 'forrest run' works fine.
>
> sorry, this is wrong; it works except the plugins as in 0.7.
> after performing steps 1 and 2, but it still doesn't work due
> to some location-map thing?!
>   Could not find ... [org.apache.cocoon.components.modules.input.InputModule/lm]

Someone else just had a similar problem and it turned out being due to
using the wrong version of the plugin.  Plugins have been modified at
this point to use the new locationmap feature but this wasn't
supported in 0.7.  You might want to recheck what version of each
plugin you're using.
--tim

Mime
View raw message