forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Crossley <cross...@apache.org>
Subject Re: pdf generation breaks
Date Wed, 01 Feb 2006 11:52:04 GMT
David Crossley wrote:
> Joao Miguel Ferreira wrote:
> > Hello all,
> > 
> > I'm having severe problems with my forrest doc.
> > 
> > Some of my images come out ok in HTML but not in PDF. I get the error
> > bellow in several (apparently) unrelated situations.
> > 
> > ---------------------------------------------
> > X [0]                       samples/sample.pdf  BROKEN:
> > org.apache.fop.apps.FOPException: No meaningful layout in block after
> > many attempts.  Infinite loop is assumed.  Processing halted.
> > ---------------------------------------------
> > 
> > I really need help on this, please someone !!!!
> > 
> > thx
> > jmf
> > 
> > PS: a previous post mentioned size problems but I'm not getting the same
> > results....
> 
> Does the 'forrest seed site' work for you?
> It uses a <figure> element in samples/samples.xml

I just tried that with the current trunk 0.8-dev.
It seems that using the PNG which is generated from
and SVG does not appear in the PDF. However a pre-prepared
GIF or PNG are both okay.

<figure src="../images/project.png" alt="generated PNG from SVG"/>
<figure src="../images/project-logo.gif" alt="pre-prepared GIF"/>
<figure src="../images/icon.png" alt="pre-prepared PNG"/>

Have not tried with 0.5.1 sorry.

-David

Mime
View raw message