forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Torsten Stolpmann <Torsten.Stolpm...@verit.de>
Subject Re: problem with image
Date Tue, 31 Jan 2006 21:24:45 GMT


Ross Gardler wrote:
> Joao Miguel Ferreira wrote:
>> Hello all,
>>
>> I'm having problems inserting one parfticular image on my document. I'm
>> using: forrest 0.5.1, document-v12.dtd.
>>
>> The line that causes problems is (the 'figure' item):
>>
>> ----------------------------
>> previous text</p>
>> <figure src="images/tubos.gif" alt=""/>
>> <p>next text...
>> --------------------------
>>
>> If I comment it out it works fine.
>>
>>
>> The error messagem I get is (the fop part):
>>
>> ----------------------------------------------------
>> * [0]   0.025s 1.1Kb   hello.pdf
>> * [0]   0.029s 2.8Kb   skin/page.css
>> X [0]                       samples/sample.pdf  BROKEN:
>> org.apache.fop.apps.FOPException: No meaningful layout in block after
>> many attempts.  Infinite loop is assumed.  Processing halted.
>> * [27]  0.175s 12.3Kb  samples/ehtml-sample.html
>> ---------------------------------------------------
>>
>> I have another image in the document that works fine...
>>
>> Any hints ?
> 
> I'm not sure if this is the same symptoms or not, search the user 
> archives and the issue tracker for more info, but...
> 
> There are reported problems with large images in PDF documents. Is this 
> image particularly large?
> 
> Ross

I can confirm this suspicion, seen this before. What is basically going 
on here is that FOP is unable to place this image in a sensible 
position. Try rescaling the picture or limit the width/height manually.

HTH,

Torsten

Mime
View raw message