forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Greg - VACO" <greg.v...@cox.net>
Subject RE: problem with image
Date Wed, 01 Feb 2006 01:30:07 GMT
Sorry I didn't originally reply on-list:

I've been struggling with this exact same problem, please see
http://issues.apache.org/jira/browse/FOR-413.  Briefly, I found that I
received that ugly error when I had tall, thin image.  Through trial-n-error
I found if your height is greater than 540px and your image is thinner than
451px, you get the error.  The easy work-around is to make it either shorter
or fatter, but the minimum ratio seems to be 540:451.  As to why this works,
I don't really know.

Incidentally, I'm using Forrest Head.

-- Greg

-----Original Message-----
From: Joao Miguel Ferreira [mailto:jmf@estg.ipvc.pt] 
Sent: Tuesday, January 31, 2006 11:00 AM
To: user@forrest.apache.org
Subject: problem with image

Hello all,

I'm having problems inserting one parfticular image on my document. I'm
using: forrest 0.5.1, document-v12.dtd.

The line that causes problems is (the 'figure' item):

----------------------------
previous text</p>
<figure src="images/tubos.gif" alt=""/>
<p>next text...
--------------------------

If I comment it out it works fine.


The error messagem I get is (the fop part):

----------------------------------------------------
* [0]   0.025s 1.1Kb   hello.pdf
* [0]   0.029s 2.8Kb   skin/page.css
X [0]                       samples/sample.pdf  BROKEN:
org.apache.fop.apps.FOPException: No meaningful layout in block after
many attempts.  Infinite loop is assumed.  Processing halted.
* [27]  0.175s 12.3Kb  samples/ehtml-sample.html
---------------------------------------------------

I have another image in the document that works fine...

Any hints ?

thx

jmf





Mime
View raw message