forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thorsten Scherler <thors...@apache.org>
Subject Re: forrest output charset mismatch with httpd
Date Tue, 31 Jan 2006 08:12:08 GMT
El mar, 31-01-2006 a las 00:15 -0600, Brian M Dube escribió:
> On 1/30/06, Yonik Seeley <yseeley@gmail.com> wrote:
> > Forrest is creating UTF-8 documents, but the apache httpd servers
> > don't seem configured to recognize the "meta http-equiv" charset
> > declarations in the html docs, and default to latin-1.
> >
> > It looks like all users of forrest at apache (save forrest.apache.org)
> > are experiencing this problem.
> >
> > Example: http://incubator.apache.org/solr/who.html which I just set up.
> > Notice the mangled accented "c" in Gospodnetic.
> 
> It renders as UTF-8 for me. I believe the charset declaration informs
> the browser, not the server, what to expect.
> 

Actually the httpd server "renders" the html pages in "c", that is right
default configuration
http://marc.theaimsgroup.com/?t=113785471000001&r=1&w=2

I actually run into this problem on the zone server.
http://marc.theaimsgroup.com/?l=forrest-dev&m=113793333805926&w=2

Then I started to apply the UTF-8 settings on httpd and run as well into
the problem of having to restart the httpd
http://marc.theaimsgroup.com/?t=113813801500002&r=1&w=2

It sounds that you have actually tried the .htaccess entry:
AddDefaultCharset UTF-8

I am not sure whether the httpd for the incubator is configured the same
aas the one for forrest but David pointed out that you sometimes "Need
to enable the use of .htaccess files". 

Can you try to set "AddDefaultCharset UTF-8" in the .htaccess file,
upload it and see what it gives. If nothing happens you need to ask on
@infra whether .htaccess files are enabled.

HTH
-- 
thorsten

"Together we stand, divided we fall!" 
Hey you (Pink Floyd)


Mime
View raw message