forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From fabian_muel...@open-tk.de (Fabian Müller)
Subject No pipeline matched request: error:site:plugins
Date Wed, 09 Nov 2005 13:35:13 GMT
Hello,

I started with "forrest seed". My problem is that when I delete these
two lines from site.xml

<plugins label="Plugins" href="pluginDocs/plugins_0_70/" tab="plugins">
</plugins>

I get the following error when I type "forrest site":

* [25/7]    [5/16]    1.107s 5.0Kb   index.html
X [0]                                     error:site:plugins    BROKEN: No pipeline matched
request: error:site:plugins
* [30/2]    [0/0]     0.276s 4.8Kb   index.pdf
* [31/1]    [0/0]     0.08s  238b    skin/images/rc-t-l-5-1header-2tab-selected-3tab-selected.png
* [32/0]    [0/0]     0.087s 228b    skin/images/rc-t-l-5-1header-2tab-unselected-3tab-unselected.png
Logging Error: Writing event to closed stream.
Total time: 0 minutes 15 seconds,  Site size: 55.596 Site pages: 20

BUILD FAILED
/home/fabian/opt/apache-forrest-0.7/main/targets/site.xml:41: Java returned: 1

Total time: 21 seconds

A similar problem occurs when I delete the <external-refs> section
from site.xml.

I copyed my tabs.xml to the end of this mail.

Can anybody explain this behaviour to me and tell me how I can delete
these sections? Thanx very much in advance.

Fabian Müller

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE tabs PUBLIC "-//APACHE//DTD Cocoon Documentation Tab V1.1//EN" "http://forrest.apache.org/dtd/tab-cocoon-v11.dtd">

<tabs software="MyProj"
  title="MyProj"
  copyright="Foo"
  xmlns:xlink="http://www.w3.org/1999/xlink">

</tabs>

Mime
View raw message