forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Prasanna Narayanan <nnprasa...@gmail.com>
Subject Help with forrest.properties
Date Sat, 05 Nov 2005 10:20:43 GMT
HI I am a novice in forrest. I have a problem when i try to follow the
installation instructions ..

When I start with forrest run

It says

 Warning: JAVA_HOME environment variable is not set.
> > If build fails because sun.* classes could not be found
> > you will need to set the JAVA_HOME environment variable
> > to the installation directory of java.
> >
> > Buildfile: c:\apache-
> > forrest-0.7\main\forrest.build.xml
> >
> > check-java-version:
> > This is apache-forrest-0.7
> > Using Java 1.5 from D:\Program Files\Java\jre1.5.0_04
> >
> > init-props:
> > Created dir: C:\Documents and Settings\user\build\tmp
> >
> > init-plugins:
> > Copying 1 file to C:\Documents and Settings\user\build\tmp
> > Copying 1 file to C:\Documents and Settings\user\build\tmp
> > Copying 1 file to C:\Documents and Settings\user\build\tmp
> > Copying 1 file to C:\Documents and Settings\user\build\tmp
> > Installing plugin: org.apache.forrest.plugin.output.pdf
> >
> > check-plugin:
> > org.apache.forrest.plugin.output.pdf is not available in the build dir
> >
> > fetch-plugins-descriptors:
> > Fetching plugins descriptor:
> > http://forrest.apache.org/plugins/plugins.xml
> > Getting: http://forrest.apache.org/plugins/plugins.xml
> > Error getting http://forrest.apache.org/plugins/plugins.xml to
> > C:\Documents and
> > Settings\user\build\tmp\plugins- 1.xml
> > Fetching plugins descriptor:
> > http://forrest.apache.org/plugins/whiteboard-plugin
> > s.xml
> > Getting: http://forrest.apache.org/plugins/whiteboard-plugins.xml
> > Error getting http://forrest.apache.org/plugins/whiteboard-plugins.xmlto C:\Doc
> > uments and Settings\user\build\tmp\plugins- 2.xml
> >
> > WARNING
> > =======
> >
> > Unable to load plugin list number 1 from http://forrest.apache.org/p
> > lugins/plugins.xml.
> > Any plugins identified in this plugin list cannot be installed
> > automatially, see further errors below.
> >
> > WARNING
> > =======
> >
> > Unable to load plugin list number 2 from http://forrest.apache.org/p
> > lugins/whiteboard-plugins.xml.
> > Any plugins identified in this plugin list cannot be installed
> > automatially, see further errors below.
> >
> > unpack-plugin:
> >
> > ERROR
> > =====
> >
> > Unable to retrieve the org.apache.forrest.plugin.output.pdf plugin.
> > There may be more information about the reason for this in output
> > above. The usual cause is that Forrest has been unable to download
> > the plugin descriptor file that indicates where this plugin is to be
> > downloaded from. If you are behind a firewall then set the proxy.host
> > and proxy.port values in the forrest.properties file.
> >
> > You may also like to check the value of the
> > forrest.plugins.descriptors property in the forrest.properties file
> > and ensure that the locations indicated by that value are accessible
> > (note there should be no spaces in this property).
> >
> >
> > BUILD FAILED
> > c:\apache-forrest-0.7
> > \main\targets\plugins.xml:334: The following error occurred while
> > executing this
> > line:
> > c:\apache-forrest-0.7
> > \main\targets\plugins.xml:351: The following error occurred while
> > executing this
> > line:
> > c:\apache-forrest-0.7
> > \main\targets\plugins.xml:99: Unable to install required plugins. See
> > error mess
> > ages above for more detail.
> >
> > Total time: 48 seconds
> >
> > 1) I would like to know what is the settings i need to change for
environment variables
2) I would also be happy to have a sample forrest.properties file with proxy
editing. As many ppl i use proxy thru our organization's Intranet.

Help me to solve the issue.. Thanks in advance.
Mime
View raw message