forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Crossley <cross...@apache.org>
Subject Re: Creating site...
Date Mon, 07 Nov 2005 22:55:08 GMT
Flavio Cordova wrote:
> David Crossley wrote:
> > Flavio Cordova wrote:
> > > I'm having two problems when generating the html files using forrestbot
> > (or
> > > forrest site):
> > > 1) I have create a directory under src/documentation/content/xdocs and
> > used
> > > them on some images using <figure src="images/prounit/mainscreen.jpg"
> > alt=
> > > "..."/>. It works pretty fine both using forrest run and forrest site
> > but
> > > the resulting PDF file doesn't show any image. Is there something I
> > should
> > > do to fix it ?
> >
> > I don't know if this is related, but have you tried
> > http://forrest.apache.org/docs/faq.html#pdf_images
> 
>  This document mentions that some formats (BMP, GIF, JPG, TIFF and EPS) are
> natively handled by FOP... Since all my images are jpg files shouldn't it be
> already working ?

I don't know either, thought it might be worth a try.
Anyway, the issue rang a bell for me ...
http://issues.apache.org/jira/browse/FOR-635
"images not reproduced in PDFs, if sources are in xdocs/images directory"

> > 2) Also under xdocs I've create a directory called samples. In this
> > > directory I have three files: result.xml, template.xls and default.css.
> > When
> > > I use forrest run all these files are available but when I generate the
> > > documentation (forrest site) just the xml files is copied to the
> > destination
> > > directory. The two other files are missing...
> > > Thanks for all !!!
> >
> > Are these files linked to from your other pages?
> > See the bottom of
> > http://forrest.apache.org/docs_0_70/upgrading_07.html#raw
> 
>  Well, I've moved the directory where these images are to the content
> directory (and not under xdocs anymore).. Then it almost worked fine.. all
> the files were correctly copied but the XML file had his content changed
> from:
>  <?xml version="1.0" ?>
> <?xml-stylesheet type='text/xsl' href='template.xsl'?>
>  to
>  <?xml version="1.0" encoding="ISO-8859-1"?><?xml-stylesheet type='text/xsl'
> href='template.xsl'?>
> *<!DOCTYPE ProUnitExecutionLog PUBLIC "-//APACHE//DTD Documentation V1.3//EN"
> "document-v13.dtd">*
>  Is there a way to tell forrest to consider this file a plain XML file,
> avoiding it to change the content ?

Forrest's default internal xml serializer adds the doctype.
I gather that this is a special file that you don't want
Forrest to process. I think that you need to follow the
abovementioned upgrade note to add a special match to your
project sitemap.xmap to intercept. My guess is that this
will need to use map:generate; map:serialize

-David

Mime
View raw message