forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gav...." <brightoncomput...@brightontown.com.au>
Subject Re: Trying to run forrestbot...
Date Sun, 30 Oct 2005 06:45:21 GMT

----- Original Message ----- 
From: "David Crossley" <crossley@apache.org>
To: <user@forrest.apache.org>
Sent: Sunday, October 30, 2005 10:34 AM
Subject: Re: Trying to run forrestbot...


| Gav.... wrote:
| >
| > ----- Original Message ----- 
| > From: "Gav...." <brightoncomputers@brightontown.com.au>
| > To: <user@forrest.apache.org>
| > Sent: Saturday, October 29, 2005 8:35 PM
| > Subject: Re: Trying to run forrestbot...
| > |
| > | Yes, I can ftp from the command-line no problem,
| > | I can not suspect a connection problem at the
| > | moment because the forrestbot is not even trying
| > | to make a connection, the FTP part of the script
| > | simply is not being executed at all.
| > |
| > | It may be an error in my script, but from the details
| > | I have on Forrestbot I can not see what is wrong/missing
| > | at this point, I will keep looking.
| >
| > Answering myself again, I found the problem.
| >
| > I looked inside deploy.xml and changed this line :-
| >
| >   <target name="deploy.ftp" unless="build.failed" 
description="Forrestbot:
| >     Deploy via FTP">
| >
| > to
| >
| >   <target name="deploy.ftp" unless="" description="Forrestbot:
| >     Deploy via FTP">
| >
| > So, all deploy methods will not occur on a build failure by default.
| > (You must have changed yours sometime David)
|
| No.
|
| > Whether this should be over-ridden in the user defined forrestbot file I
| > dont know, but it works now, and combined with the turning on
| > of CLI checksums in cli.xconf, only updates via ftp those files
| > that have been changed.
| >
| > It's all good :)
|
| The checksums bit is definitely good.
|
| Being able to deploy a broken site would cause problems.

True, in my case I know they are broken and am waiting for the fix for v2,
but as long as the broken parts don't change, they don't get updated and
dont get ftp'd, so are not a problem for me at this time.

This is a workaround for me, once I have a successful build, I will revert.

Gav...

|
| I wonder how i managed to do it. Perhaps it was because i do
| separate actions with the forrestbot: 'build', then investigate
| the brokenlinks reports and log files and sometimes view,
| then 'deploy'.
|
| -David
| 



-- 
No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.1.362 / Virus Database: 267.12.6/151 - Release Date: 28/10/2005



-- 
This message was scanned for spam and viruses by BitDefender.
For more information please visit http://linux.bitdefender.com/



Mime
View raw message