forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Miroslav Mocek <mmo...@seznam.cz>
Subject Re: leather-dev skins and view/viewHelper plugins
Date Thu, 29 Sep 2005 11:19:50 GMT
Sorry for misconfusing. I've already found tabs.xml... My fault.
Mirek

Miroslav Mocek wrote:

> The "pelt" skin seems to me a little too complicated. Too many tabs 
> and so on. And I don't know, how to simplify it.
> On the other hand the "leather-dev" skin seems to fit my needs 
> exactly. That's why I tried it.
> Thanks for answer, I'll try to play with the 0.8-dev.
> Mirek
>
> David Crossley wrote:
>
>> Miroslav Mocek wrote:
>>  
>>
>>> Hello,
>>>
>>> I've just downloaded forrest 0.7. I've tried to create my own site. 
>>> I've tried to change skin in forrest.properties.
>>>   
>>
>>
>> As you are a new user, it would be better to remain with
>> the default skin "pelt".
>>
>> The "leather-dev" is just what it says "development".
>> If you do want to get involved in development, then
>> use the current head of Subversion (i.e. 0.8-dev rather
>> than the 0.7 release).
>>
>> Even so, be warned that current development (codename "views")
>> is undergoing rapid change. You are welcome to help.
>>
>> -David
>>
>>  
>>
>>> I saw screenshots in documentation, the leather-dev skin is what I 
>>> want 
>>> (http://forrest.apache.org/docs_0_70/images/snapshot-view-viewHelper.png) 
>>> but I'm not able to get it.
>>>
>>> If I edit forrest.properties like this:
>>> project.skin=leather-dev
>>>
>>> start forrest run and use browser to view localhost:8888, i get 
>>> Internal Server Error :
>>> <>Message: null
>>> Description: No details available.
>>> Sender: org.apache.cocoon.servlet.CocoonServlet
>>> Source: Cocoon Servlet
>>> Request URI index.html
>>> cause Chyba funkce ElemTemplateElement: getHead
>>> request-uri /index.html
>>>
>>> I've tried to edit this line:
>>> project.required.plugins=org.apache.forrest.plugin.output.pdf,org.apache.forrest.plugin.internal.view

>>>
>>>
>>> the plugin was downloaded and installed. But I get the same Internal 
>>> Server Error.
>>>
>>> There is written in documentation, that I need also viewHelper 
>>> plugin, but I haven't found it.
>>>
>>> What's wrong? How can I get the leather-dev skin on my site?
>>> Thank You
>>> Mirek
>>>   
>>
>>
>>  
>>
>
>


Mime
View raw message