forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hugo Osorio <osorio.h...@gmail.com>
Subject error en 'forrest run'
Date Tue, 23 Aug 2005 16:20:40 GMT
Hello everybody... I have this error, and it is related to be impossible to 
download some plugins.xml

I have set the enviroment variables http_proxy & ftp_proxy to my default 
proxy.. but it remains the same error, please.. what could I do.?

thank you
---------------

zulu# forrest run
Apache Forrest. Run 'forrest -projecthelp' to list options

Buildfile: /usr/local/forrest/main/forrest.build.xml

check-java-version:
This is apache-forrest-0.8-dev
Using Java 1.4 from /usr/local/jdk1.4.2/jre

init-props:

echo-settings:

check-skin:

init-proxy:

fetch-skins-descriptors:

fetch-skin:

unpack-skins:

init-skins:

init-plugins:
Copying 1 file to /usr/local/forrest/site-author/build
Copying 1 file to /usr/local/forrest/site-author/build/tmp
Copying 1 file to /usr/local/forrest/site-author/build/tmp
Copying 1 file to /usr/local/forrest/site-author/build/tmp
Copying 1 file to /usr/local/forrest/site-author/build/tmp
Installing plugin: org.apache.forrest.plugin.input.dtdx

check-plugin:
org.apache.forrest.plugin.input.dtdx is not available in the build dir

init-props:

echo-settings:

init-proxy:

fetch-plugins-descriptors:
Fetching plugins descriptor: http://forrest.apache.org/plugins/plugins.xml
Getting: http://forrest.apache.org/plugins/plugins.xml
Error getting http://forrest.apache.org/plugins/plugins.xml to 
/usr/local/forrest/site-author/build/tmp/plugins-1.xml
Fetching plugins descriptor: 
http://forrest.apache.org/plugins/whiteboard-plugins.xml
Getting: http://forrest.apache.org/plugins/whiteboard-plugins.xml
Error getting http://forrest.apache.org/plugins/whiteboard-plugins.xml to 
/usr/local/forrest/site-author/build/tmp/plugins-2.xml

WARNING
=======

Unable to load plugin list number 1 from 
http://forrest.apache.org/plugins/plugins.xml.
Any plugins identified in this plugin list cannot be installed
automatially, see further errors below.

WARNING
=======

Unable to load plugin list number 2 from 
http://forrest.apache.org/plugins/whiteboard-plugins.xml.
Any plugins identified in this plugin list cannot be installed
automatially, see further errors below.

fetch-plugin:

unpack-plugin:

ERROR
=====

Unable to retrieve the org.apache.forrest.plugin.input.dtdx plugin.
There may be more information about the reason for this in output
above. The usual cause is that Forrest has been unable to download
the plugin descriptor file that indicates where this plugin is to be
downloaded from. If you are behind a firewall then set the proxy.host
and proxy.port values in the forrest.properties file.

You may also like to check the value of the
forrest.plugins.descriptors property in the forrest.properties file
and ensure that the locations indicated by that value are accessible
(note there should be no spaces in this property).

If all else fails you can can manually install the plugins you need
by downloading the install bundles (see
http://forrest.apache.org/pluginDocs/plugins_0_70/index.html) and unpacking
them into FORREST_HOME/build/plugins.

Note that once the plugins have been installed, they will not need
to be installed again unless you delete them or wish to upgrade them.


BUILD FAILED
/usr/local/forrest/main/targets/plugins.xml:348: The following error 
occurred while executing this line:
/usr/local/forrest/main/targets/plugins.xml:365: The following error 
occurred while executing this line:
/usr/local/forrest/main/targets/plugins.xml:107: Unable to install required 
plugins. See error messages above for more detail.

Total time: 2 minutes 37 seconds

Mime
View raw message