forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ross Gardler <rgard...@apache.org>
Subject Re: simplified docbook plugin (Was: Forrest run works but forrest doesn't)
Date Wed, 03 Aug 2005 05:05:33 GMT
Phillip Evans wrote:

It would really help if you make your replies inline as I am doing here. 
If someone This keeps the context of our discussion so that I can 
remember exactly what we are doing. I write many mails every day and I 
have a short memory ;-)

It also helps make the archives much more readable, that is if a new 
user has the same problem as you and comes to this mail in the archives 
they will see a dialog that describes how to diagnose their problem 
rather than a summary that you discovered the solution.

> Thanks for your time on this. I have done as you outlined. After running
> forrest site in testSDocbook directory I again got the message in the
> console:
> 
> BROKEN: C:\apachefriends\xampp\htdocs\apache-forrest-0.7\plugins\plugins.xml
> <The system cannot find the file specified> 
 >
> However all the plugins appeared to be retrieved and configured as you
> describe.

Yes the plugin download mechanism doesn't use a local copy of the file 
(neither does the docs build anymore, thanks to your report above).

> I checked the distribution zip file for forrest and found that
> \apache-forrest-0.7\plugins\plugins.xml was present, so copied it to where
> it should have been in my installation. I re-ran forrest site without
> problems.

How can it have been present in the distribution but not in your 
installation? Is it safe for me to assume that this is a problem local 
to you rather than in the distribution.

> I then ran forrest run in:
> FORREST_HOME/build/plugins/org.apache.forrest.plugin.input.simplifiedDocbook
> without problems, and could view sdocbook.html and .pdf
> 
> I then tried adding one of my own sdocbook documents, and again had the
> problem of no content. I checked out input.xmap, and found that it had a
> sourcetype of sdocbook-v1.0, whereas my documents are all sdocbook-v1.1
> 
> I assigned sdocbook-v1.0 to a couple of my documents, and they worked fine.
> 
> I suppose it is possible to modify input.xmap so that will accept
> sdocbook-v1.1 as well?
> 
> Where should that be done?

I've updated the plugin for version 4.1.2.5 of the plugin but there 
isn't a released 1.1 version that I can see ( 
http://www.oasis-open.org/docbook/xml/simple/ ). What is the public 
identifier you are using?

Once I know what we need to add I'll update the plugin. If you want to 
do this yourself (and supply a patch please) then take a look at 
input.xmap The supported DTD's are listed at the top of the file and you 
will need to add a matcher later in the file, it is pretty much a cut 
and past job.

> Might I suggest that on the initial plugins page on
> forrest.apache.org that a indication be placed above the download section
> that this is normally done automatically by forrest, rather than having to
> follow a link to a second page to find this out.

I've added a two sentence description on how to install plugins to the 
page as you suggest, it will appear on the site next time we update.

> Still, I have learned heaps more than I would have if it had all gone
> smoothly, as it obviously does if done right. Next time, read the
> instructions, Phillip, read the instructions.

:-))

Ross

Mime
View raw message