forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ross Gardler <rgard...@apache.org>
Subject Re: simplified docbook plugin (Was: Forrest run works but forrest doesn't)
Date Tue, 02 Aug 2005 16:52:50 GMT
Phillip Evans wrote:
> OK, here is the process I followed and the issues that I have found while
> getting forrest to work with sdocbook.
> 
> I edited forrest.properties to include the sdocbook plugin and the Open
> Office plugin.
> I put a (validated) sdocbook file and an Open Office document into 'sample'
> directory of a freshly seeded site. (I also added some sdocbook files to a
> 'manuals' subdirectory of 'sample')
> I edited site.xml to give LH Navigation to these documents.
> I ran 'forrest' to build a static site. The build was unsuccessful due to
> some broken links.
> I downloaded plugin.xml from forrest.apache.org into the plugins directory
> as the build said that file was missing. (It took me a while to figure that
> out) I then got a successful build.

What build? the build of forrest or the build of your site? I've never 
heard this one before.

There should be no need to download it manually, Forrest retrieves it 
when necessary.

What version of Forrest are you using?

> The Open Office document converted OK,(except for images) but the sdocbook
> page had only the header and LH Navigation, no content. The build listing
> shows all plugins being available and mounts them.
> 
> Following the documentation from "V5.2. How do I use DocBook as the xml
> documentation format?" as best as I was able with my limited knowledge, I
> made the following changes to sitemap.xmap in src/documentation/ :

...

> After which everything worked. I had presumed that just declaring the
> sdocbook plugin would do the trick. I needed to move sdocbook2document.xsl
> because of the <map:transform src= declaration I added above.

This is mixing two issues. That FAQ is about setting up separate 
handling of docbook files. It has nothing to do with the sdocbook 
plugin. You are correct in assuming that you just installing the 
sdocbook plugin should work for you. I'd like to get to the bottom of 
why it didn't work in your case, maybe you uncovered a bug:

You do not seem to have changed any core Forrest files so lets start again:

rm -RF FORREST_HOME/build/plugins

(this will remove all currently installed plugins)

rm the plugins.xml file you downloaded manually.

cd PROJECT_HOME
mkdir testSDocbook
cd testSDocbook
forrest seed

add org.apache.forrest.plugin.input.simplifiedDocbook to the 
project.required.plugins property of forrest.properties file

forrest site

When forrest runs it should retrieve the sdocbook plugin from the 
forrest site. If you get any errors such as the missing plugins.xml file 
please post the relevant output from you the console in which you ran 
the above command.

If you get no errors do this:

cd FORREST_HOME/build/plugins/org.apache.plugin.input.simplifiedDocbook
forrest run
http://localhost:8888/samples/sdocbook.html

This will load a page generated from a simplified docbook file in the 
plugin docs.

I just did this with my Forrest install, this works just fine. However, 
I am using SVN head so it would be great if you could test it with 
whatever version of Forrest you are using.

Once we have verified that this works (or debugged why it doesn't work) 
we'll get your sdocbook files working in the new sample site we did.

Ross



Mime
View raw message