forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Johannes Schaefer <johannes.schae...@uidesign.de>
Subject Re: Forrest run works but forrest doesn't
Date Tue, 02 Aug 2005 06:39:53 GMT

Phillip Evans schrieb:
> I am running under windows xp. I am running 'forrest' and 'forrest run' from
> the site directory that I ran forrest seed in. $FORREST_HOME is set to the
> directory above the site directory, ie 'apache-forrest-0.7'. 

Putting your project directory below apache-forrest-0.7 may cause
some problems.

You may try it like this:
  FORREST_HOME=c:\apache-forrest-0.7
  project dir: c:\Projects\myNewProject

Below the forrest directory is its own documentation and stuff,
so forrest may get confused (although I'd say forrest shouldn't
if you have it like this: c:\apache-forrest-0.7\myProjectDir,
but then: Life's like a box of chocolates ;-)

Johannes


> Listed below is
> the broken links file generated by the build, the majority of which I am
> guessing relates to the failure to generate the LH Navigation.
> 
> I did a lot of playing around to get sdocbook files working under 'forrest
> run', even with the sdocbook plugin, so I probably made some changes that
> affected 'the 'forrest' command that I didn't reverse.
> 
> My next step is to start a new seed site and apply my changes one step at a
> time and test with both 'forrest run' and 'forrest' at each stage. What
> better way to learn?
> 
> 
> 
> - <broken-links>
> - <link message="No pipeline matched request: samples/error:ext:webapp"
> uri="samples/error:ext:webapp">
>   <referrer uri="samples/sample.html" /> 
>   </link>
> - <link message="No pipeline matched request: samples/error:site:faq"
> uri="samples/error:site:faq">
>   <referrer uri="samples/sample.html" /> 
>   </link>
> - <link message="No pipeline matched request:
> samples/error:ext:forrest/linking" uri="samples/error:ext:forrest/linking">
>   <referrer uri="samples/sample.html" /> 
>   </link>
> - <link message="No pipeline matched request:
> samples/error:site:samples/faq" uri="samples/error:site:samples/faq">
>   <referrer uri="samples/sample.html" /> 
>   </link>
> - <link message="No pipeline matched request: error:ext:forrest"
> uri="error:ext:forrest">
>   <referrer uri="index.html" /> 
>   </link>
> - <link message="No pipeline matched request: samples/error:ext:forrest"
> uri="samples/error:ext:forrest">
>   <referrer uri="samples/sample.html" /> 
>   </link>
> - <link
> message="C:\apachefriends\xampp\htdocs\apache-forrest-0.7\plugins\plugins.xm
> l (The system cannot find the file specified)"
> uri="pluginDocs/plugins_0_70/index.html">
>   <referrer uri="linkmap.html" /> 
>   <referrer uri="index.html" /> 
>   <referrer uri="samples/sample.html" /> 
>   <referrer uri="samples/index.html" /> 
>   <referrer uri="samples/static.html" /> 
>   <referrer uri="samples/subdir/index.html" /> 
>   </link>
> - <link message="No pipeline matched request: samples/error:site:samples"
> uri="samples/error:site:samples">
>   <referrer uri="samples/sample.html" /> 
>   </link>
> - <link message="No pipeline matched request: old_site/test1.xml"
> uri="/old_site/test1.html">
>   <referrer uri="samples/sample.html" /> 
>   </link>
> - <link message="No pipeline matched request: samples/error:ext:linking"
> uri="samples/error:ext:linking">
>   <referrer uri="samples/sample.html" /> 
>   </link>
> - <link message="No pipeline matched request:
> samples/error:site:hello_print" uri="samples/error:site:hello_print">
>   <referrer uri="samples/sample.html" /> 
>   </link>
> - <link message="No pipeline matched request: error:site:plugins"
> uri="error:site:plugins">
>   <referrer uri="index.html" /> 
>   </link>
> - <link message="No pipeline matched request: samples/error:site:index"
> uri="samples/error:site:index">
>   <referrer uri="samples/sample.html" /> 
>   </link>
> - <link message="No pipeline matched request: samples/error:site:plugins"
> uri="samples/error:site:plugins">
>   <referrer uri="samples/sample.html" /> 
>   </link>
> - <link message="No pipeline matched request:
> samples/error:ext:forrest/webapp" uri="samples/error:ext:forrest/webapp">
>   <referrer uri="samples/sample.html" /> 
>   </link>
> - <link message="No pipeline matched request:
> samples/error:site:samples/sample/section"
> uri="samples/error:site:samples/sample/section">
>   <referrer uri="samples/sample.html" /> 
>   </link>
>   </broken-links> 
> 
> -----Original Message-----
> From: CFAS Webmaster [mailto:webmaster@cfas.org] 
> Sent: Tuesday, August 02, 2005 12:09 PM
> To: user@forrest.apache.org
> Subject: Re: Forrest run works but forrest doesn't
> 
> Phil,
> 
>   What error is forrest giving?  From where are you running either command
> and to what directory is $FORREST_HOME set, if any? 
> 
>   I can't remember seeing this behavior so I don't have any additional ideas
> right now.  A copy & paste of the failed command would help.
> 
> -Paul
> 
> Phillip Evans wrote:
> 
> 
>>A rank beginner here. It's taken a while but I have forrest accepting 
>>sdocbook files, and rendering them in both html and pdf, (with a bit of 
>>a problem but more on that later) This works ok with the 'forrest run' 
>>command but with 'forrest' the build fails, with none of the new 
>>documents included in the static site, only the documents from the 
>>original 'seed' are rendered. The LH menu doesn't appear either, 
>>whereas using 'forrest run' it does.
>>
>>Can someone point me to documentation that might assist me? I'm 
>>guessing its something simple in the setup that I have missed, but I 
>>seem to be reading the same thing over and over with no flashes of
> 
> inspiration. My head hurts.
> 
>>PhilE
>>
>>
>> 
>>
> 
> 
> 
> 


-- 
User Interface Design GmbH * Teinacher Str. 38 * D-71634 Ludwigsburg
Fon +49 (0)7141 377 000 * Fax  +49 (0)7141 377 00-99
Geschäftsstelle: User Interface Design GmbH * Lehrer-Götz-Weg 11 * D-81825 München
www.uidesign.de

Buch "User Interface Tuning" von Joachim Machate & Michael Burmester
www.user-interface-tuning.de

Mime
View raw message