forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Phillip Evans" <pev...@wukwuk.com>
Subject RE: simplified docbook plugin (Was: Forrest run works but forrest doesn't)
Date Wed, 03 Aug 2005 03:44:51 GMT
Ross,

Thanks for your time on this. I have done as you outlined. After running
forrest site in testSDocbook directory I again got the message in the
console:

BROKEN: C:\apachefriends\xampp\htdocs\apache-forrest-0.7\plugins\plugins.xml
<The system cannot find the file specified> 

However all the plugins appeared to be retrieved and configured as you
describe.

I checked the distribution zip file for forrest and found that
\apache-forrest-0.7\plugins\plugins.xml was present, so copied it to where
it should have been in my installation. I re-ran forrest site without
problems.

I then ran forrest run in:
FORREST_HOME/build/plugins/org.apache.forrest.plugin.input.simplifiedDocbook
without problems, and could view sdocbook.html and .pdf

I then tried adding one of my own sdocbook documents, and again had the
problem of no content. I checked out input.xmap, and found that it had a
sourcetype of sdocbook-v1.0, whereas my documents are all sdocbook-v1.1

I assigned sdocbook-v1.0 to a couple of my documents, and they worked fine.

I suppose it is possible to modify input.xmap so that will accept
sdocbook-v1.1 as well?

Where should that be done?

It may have been that downloading the plugins manually meant that they were
not installed correctly. Might I suggest that on the initial plugins page on
forrest.apache.org that a indication be placed above the download section
that this is normally done automatically by forrest, rather than having to
follow a link to a second page to find this out.

Still, I have learned heaps more than I would have if it had all gone
smoothly, as it obviously does if done right. Next time, read the
instructions, Phillip, read the instructions.

Now to try out the testSDocbook site with some of my documents.

Thanks again, Ross.

I am using forrest-0.7

-----Original Message-----
From: Ross Gardler [mailto:rgardler@apache.org] 
Sent: Wednesday, August 03, 2005 2:53 AM
To: user@forrest.apache.org
Subject: Re: simplified docbook plugin (Was: Forrest run works but forrest
doesn't)

Phillip Evans wrote:
> OK, here is the process I followed and the issues that I have found 
> while getting forrest to work with sdocbook.


Once we have verified that this works (or debugged why it doesn't work)
we'll get your sdocbook files working in the new sample site we did.

Ross





Mime
View raw message