forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Crossley <cross...@apache.org>
Subject Re: Problem with site.xml and menu for hidden items
Date Thu, 21 Jul 2005 14:42:12 GMT
Mickael Remond wrote:
> David Crossley wrote:
> >If you still have trouble, then create an issue in our Issue Tracker
> >and attach a screenshot to help explain your problem.
> 
> The problem can be demonstrated online. For exemple, here is a normal 
> page that show the correct menu:
> http://www.process-one.net/en/projects/ejabberd/releases/index.html
> 
> If you click on one of the link on the page you reach the following 
> page, that display all menu entries in every topic/tab.
> http://www.process-one.net/en/projects/ejabberd/releases/release_0.9.1.html
> 
> The corresponding piece of site.xml is something like:
>       <release label="Release notes" href="releases/index.html" 
> 
>                description="Latest release notes">
>         <index href="releases/index.html"/>
>         <release2 href="releases/release_0.9.1.html"/>
>         <release1 href="releases/release_0.9.html"/>
>       </release>

As well as the reference that Diwaker provided, also look
at the forrest/site-author for our site.xml
e.g. the "tools" section. Something like this might
do the trick ...
  <release label="Release notes" href="releases/" 
     description="Latest release notes">
    <index href="index.html"/>
    <release2 href="release_0.9.1.html"/>
    <release1 href="release_0.9.html"/>
  </release>

David

> My question is the following: How is it possible to hide link under a 
> certain level while keeping a proper rendering of the menu ? Is it 
> possible ?
> 
> Thank you in advance.
> 
> -- 
> Micka?l R?mond

Mime
View raw message