forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ross Gardler <rgard...@apache.org>
Subject Re: Java jre vs. jdk
Date Sun, 29 May 2005 23:52:53 GMT
Maurice Lanselle wrote:
> Addi said the following on 28/05/2005 16:39:
> 
>> Hello,  I've a quick question.  I have Java's jre 1.5 on my machines 
>> and 0.6 worked fine, when I went to build 0.7 though, I couldn't get 
>> it to work until I installed jdk 1.5.  I assume this because I am 
>> using a dev version and building?  The docs (FAQ and the SVN docs) 
>> only say that it requires Java 1.4 with no indication as to whether 
>> the jre or jdk is desired.  Will the released version of 0.7 work with 
>> the jre?
>>
>> - Addi
>>
> Me too, exactly.  I started to download the JDK and balked at the size / 
> amount of disk space required.  I would like to try Eclipse, which seems 
> to only need a JRE.  Will I be able to build Forrest with Eclipse+JRE if 
> I don't install the JDK?  How soon will pre-built distributions of 0.7 
> be available?

If you wnat to work with SVN head then you need to compile Forrest. To 
complie Forrest you need a Java compiler. The (sun) Java compiler is in 
the JDK, not the JRE.

However, when we produce a release version it is precompiled. Hence it 
does not need the compiler, hence it only needs the JRE.

Ross

Mime
View raw message