forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ross Gardler <rgard...@apache.org>
Subject Re: Forrest Coocon eclipse?
Date Mon, 23 May 2005 09:13:38 GMT
Bhatia Praveen, HCLT-Japan wrote:
> Hello,
>     Diagnosed this problem further. Looks like the classes used in new
> ForrestRunner.java are part of the dev version of eclipse, so are not found
> in eclipse 3.0.2.

Thanks, I'll make that clear in the readme then, I am using 3.1M7 nd had 
not tested in earlier versions. Thanks for the info.

>    However, old ForrestRunner.java with older WTPM1.0 and WTP-M2.0 in
> combination (with some adjustment to package names) worked and I could
> export the plugin to eclipse. The 'seed' and 'new xdoc' option for the site
> menuitem worked. 

Yes, I only updated those classes the other day. Aparrently the original 
WTP drop is no longer available so we needed the update.

> However, Trying, to run the forrest xdoc files in server,
> gives error......
> 
> First, eclipse forrest plugin asks the preferences for forrest home to be
> set for the plugin.
> 
> Now if we set c:\forrest as the Forrest Home, it can locate the
> forrest.build.xml,  but then gives the following error from the server:
> CASE 1: If we set FORREST_HOME=C:\forrest in preferences and the
> FORREST_HOME variable in cmd shell:
> ==>
> C:\forrest\main\forrest.build.xml:63: C:\forrest\main\"C:\forrest"\lib\core
> not found.
> at
> org.apache.tools.ant.types.AbstractFileSet.getDirectoryScanner(AbstractFileS
> et.java:342)
> at org.apache.tools.ant.types.Path.list(Path.java:331)
> 
> CASE 2: To avoid the above problem, left the cmd line setting blank.
> However, this also gives error. Error when FORREST_HOME is left blank in cmd
> shell, but set as c:\forrest in the preferences
> ==>
> C:\forrest\main\forrest.build.xml:63:
> C:\forrest\main\{$env.FORREST_HOME}"\lib\core not found.
> at
> org.apache.tools.ant.types.AbstractFileSet.getDirectoryScanner(AbstractFileS
> et.java:342)
> at org.apache.tools.ant.types.Path.list(Path.java:331)
> 
> ============================

Could you raise those as issues on our issue tracker please, your 
diagnosis is extremely valuable and it may well get lost in the mailing 
list. See http://issues.cocoondev.org/secure/CreateIssue!default.jspa


> What is the correct procedure for setting this path for eclipse plugin?

I have FORRET_HOME set in the environment and do nothing in the plugin. 
The plugin is designed to pick up FORREST_HOME from the env variable and 
place it in preferences.

However, this is a certainly a bug, it should work in both your cases above.

(thanks for the very clear analysis of the problems, I will fix this 
stuff soon)

Ross

Mime
View raw message