forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Addi <a...@rocktreesky.com>
Subject Re: Problem with menu links
Date Wed, 18 May 2005 20:01:01 GMT
*sigh* Sorry bout wasting your time on that.  I definitely got confused 
when editing the tabs and site files and misnamed the two that weren't 
working by forgetting the "-".  I guess I will do better if I copy and 
paste between the two files.

I figured I didn't need to save the one as xml but I was just seeing if 
it made a difference.  Does forrest recognize the new OOo format .odt as 
well?

Thanks for your patience.
- Addi

Ross Gardler wrote:

> Addi wrote:
>
>> Hello all,
>>
>> I started testing out OOo files today and am having trouble with the 
>> menu links to them.  I am just doing static generation right now with 
>> Forrest 0.6 on WinXP.
>>
>> Here's my process:
>> - Create a directory called "formats" in 
>> ..\src\documentation\content\xdocs
>> -Create 2 files (one OOo .xml and one OOo .sxw) and save into formats 
>> folder
>
>
> There is no need to creatre the XML file, Forrest does the conversions 
> itself.
>
>> - Copy the samples\openoffice-writer.sxw file into formats folder
>> - Edit site.xml suchly:
>>  <formats label="Formats" href="formats/" tab="formats">
>>    <oo-docbook label="OOo DocBook" href="TestDBk.html" description="A 
>> OOo DocBook Test"/>
>>    <oo-writer label="OOo Writer" href="openoffice-writer.html" 
>> description="A OOo Writer Test"/>
>>    <oo-text label="OOo Text" href="TestOOo.html" description="A OOo 
>> Text Test" />
>>  </formats>
>> - Edit tabs.xml suchly:
>>  <tab id="formats" label="Formats" dir="formats" 
>> indexfile="Test-DBk.html">
>>    <tab id="openofficetext" label="Open Office Text" dir="formats" 
>> indexfile="openoffice-writer.html"/>
>>    <tab id="ootext" label="OOo Text" dir="formats" 
>> indexfile="Test-OOo.html"/>
>>  </tab>
>> Run forrest
>>
>> When I go to look at the site, here's what happens:
>> I click the Formats tab and I get the TestDbk.html file properly.
>> I click on the Menu item - OOo DocBook and I get an error stating 
>> that whole/path/to/TestDBk.html cannot be found.
>
>
> The name of the file in tabs is Test-Dbk.html which is different from 
> the one in site.xml (TestDbk.html). Since it works in tabs then I 
> guess that is the reason site.xml doesn't.
>
>> Same happens for the Menu item - OOo Text (TestOOo.html).
>
>
> You do not mention a TestOOo.* file. What do you have and where is it?
>
> Ross
>
>
>



Mime
View raw message