forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bhatia Praveen, HCLT-Japan" <prav...@hcltech.co.jp>
Subject RE: Forrest Coocon eclipse?
Date Mon, 23 May 2005 07:48:03 GMT
Hello,
    Diagnosed this problem further. Looks like the classes used in new
ForrestRunner.java are part of the dev version of eclipse, so are not found
in eclipse 3.0.2.

   However, old ForrestRunner.java with older WTPM1.0 and WTP-M2.0 in
combination (with some adjustment to package names) worked and I could
export the plugin to eclipse. The 'seed' and 'new xdoc' option for the site
menuitem worked. However, Trying, to run the forrest xdoc files in server,
gives error......

First, eclipse forrest plugin asks the preferences for forrest home to be
set for the plugin.

Now if we set c:\forrest as the Forrest Home, it can locate the
forrest.build.xml, but then gives the following error from the server:
CASE 1: If we set FORREST_HOME=C:\forrest in preferences and the
FORREST_HOME variable in cmd shell:
==>
C:\forrest\main\forrest.build.xml:63: C:\forrest\main\"C:\forrest"\lib\core
not found.
at
org.apache.tools.ant.types.AbstractFileSet.getDirectoryScanner(AbstractFileS
et.java:342)
at org.apache.tools.ant.types.Path.list(Path.java:331)

CASE 2: To avoid the above problem, left the cmd line setting blank.
However, this also gives error. Error when FORREST_HOME is left blank in cmd
shell, but set as c:\forrest in the preferences
==>
C:\forrest\main\forrest.build.xml:63:
C:\forrest\main\{$env.FORREST_HOME}"\lib\core not found.
at
org.apache.tools.ant.types.AbstractFileSet.getDirectoryScanner(AbstractFileS
et.java:342)
at org.apache.tools.ant.types.Path.list(Path.java:331)

============================
What is the correct procedure for setting this path for eclipse plugin?

Thanks and Regards
Praveen

-----Original Message-----
From: Bhatia Praveen, HCLT-Japan [mailto:praveen@hcltech.co.jp] 
Sent: Monday, May 23, 2005 1:21 PM
To: user@forrest.apache.org
Subject: RE: Forrest Coocon eclipse?

Hello,
     Tried further with the installation of the Forrest plugin. By changing
the workspace to a new workspace, downloading org.burrokeet.serveletEngine
and WTP progressed further but then got stuck at the following
classes/methods being not found in ForrestRunner.java:
IWorkbenchBrowserSupport
IWebBrowser
getBrowserSupport();

Perhaps these are from older WTP of IBM (not sure). Anyway, how do I get
them or circumvent them.

The relevant code snippet where the error comes in ForrestRunner.java is as
follows:
===========================================================================
                    url = new URL("http://localhost:8888");
                    IWorkbenchBrowserSupport browserSupport =
WebBrowserUIPlugin
 
.getInstance().getWorkbench().getBrowserSupport();
                    IWebBrowser browser = browserSupport.createBrowser(
                            IWorkbenchBrowserSupport.LOCATION_BAR
                                    |
IWorkbenchBrowserSupport.NAVIGATION_BAR,
                            null, null, null);

=======================================================================

Praveen





-----Original Message-----
From: Ross Gardler
To: user@forrest.apache.org
Sent: 2005/05/19 19:37
Subject: Re: Forrest Coocon eclipse?

Ross Gardler wrote:
> Bhatia Praveen, HCLT-Japan wrote:
> 
>> Hello,
>>       Thanks for the instructions. Most of it is fine but for some 
>> problems
>> for WTP.......
>>       Tried the steps given in the readme for forrest plugin for
eclipse.
>> Got stuck in the following as the location of .zip doesn't exist any 
>> longer.
>>
> 
> Hmmm... The WTP package has gone way passed that early release now and
I 
> have yet to update the plugin to work with the latest milestone
releases.
> 
> I'll do those conversions now as it needs to be done and someone on 
> Burrokeet hit the same problem earlier today.
> 
> I'll notify via this list when the update is done.

I've now updated the plugin to work with WTP1.0M4. The readme has been 
updated, it's the same apart from we now work with Eclipse 3.1M* and 
WTP1.0M4.

Since you stared installing on the 3.0 version of Eclipse you should be 
OK sticking with that (although it is untested here).

If you start from the same place you were up to in the install 
instructions it should work, although you may need to update the 
dependant packages for the WTP using Eclipses update manageer.

Please let us know if this works as you will be the first to test this 
new configuration.

Ross

Mime
View raw message