forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Audun V. Nes" <far2f...@gmail.com>
Subject Building site with Ant from Eclipse 3.0 1?
Date Sun, 10 Apr 2005 19:55:25 GMT
Hi

I am trying to get Forrest to work from within Eclipse 3.0.1 but
are having a few problems and wanted to hear if anyone has succesfully
set that up. Based on the chapter "Invoking Forrest from Ant" in
the Forrest docmentation, I have created the following Ant build file:

<project name="CCCP Website" default="post-build">

     <property environment="env"/>
     <property name="forrest.home" value="${env.FORREST_HOME}"/>
     <import file="${env.FORREST_HOME}/forrest.build.xml"/>

     <target name="post-build" depends="site">
       <echo>Building Forrest website</echo>
     </target>
</project>

The enviroment variable FORREST_HOME is correctly set in my system 
enviroment,
and I can build my site by running "forrest" from command line without 
problems.

I was not sure where to copy xml-commons-resolver-1.1.jar, but I though
eclipse/plugins/org.apache.ant_1.6.2/lib was the right location.
I also added xml-commons-resolver-1.1.jar to the Ant classpath in Eclipse.

But when I run the build.xml file from within Eclipse I get the 
following problem:

Buildfile: C:\app\eclipse\workspace\CCCP\forrest\build.xml
init-props:
     [echo] Loading project specific properties from 
C:\app\eclipse\workspace\CCCP\forrest\forrest.properties
     [echo] Loading user specific properties from C:\Documents and 
Settings\far2fish\forrest.properties
     [echo] Loading default properties from 
C:\app\forrest\src\core\context\default-forrest.properties
    [mkdir] Created dir: C:\app\eclipse\workspace\CCCP\forrest\build\tmp
echo-settings:
check-skin:
fetch-skins-descriptors:
fetch-skin:
unpack-skins:
init-skins:
init:
-prepare-classpath:
check-contentdir:
examine-proj:
validation-props:
validate-xdocs:
BUILD FAILED: C:\app\forrest\src\core\targets\validate.xml:143: Parser 
org.apache.crimson.parser.XMLReaderImpl doesn't recognize feature 
http://apache.org/xml/features/validation/dynamic
Total time: 1 second

best regards
Audun

Mime
View raw message