forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Brondsema <d...@brondsema.net>
Subject Re: Wholesite PDF & any PDF in xdoc root are missing images ...
Date Mon, 14 Mar 2005 18:05:18 GMT
greg.vaco@cox.net wrote:
> It appears that the fo:external-graphic's src attribute is incorrect for all PDFs that
are generated from the xdoc-root directory, including wholesite.  To recreate the problem,
use Fresh-site from Forrest Head (revision 157429) and add a valid image to xdoc's index.xml:
>
> <p><img src="images/testing.gif" alt="Testing GIF"/></p>
>
> The resulting index.fo will have:
>
> <fo:external-graphic src="- - your path - - /src/documentation/resources/images///testing.gif"
/>
>
> It appears that the variable project.images-dir is being used incorrectly.  Furthermore,
if you set this variable to project.images-dir=${project.xdocs-dir}/images, the images in
the xdoc's root will be rendered correctly, but the images in sub-directories will not.
>
> I hope this makes sense.
>

First, aggregate pages (like wholesite.html/pdf) do not properly
reference images and links unless they are in the same directory.

I think project.images-dir is no longer the recommended way to use
images.  (If true, we need change
http://forrest.apache.org/docs/dev/your-project.html#images and add an
FAQ about this, or an item in an 'upgrading' doc).  Put your images with
any other 'raw' files.  See
http://forrest.apache.org/docs/dev/faq.html#link_raw

Can another developer confirm or deny this?

--
Dave Brondsema : dave@brondsema.net
http://www.splike.com : programming
http://csx.calvin.edu : student org
http://www.brondsema.net : personal

Mime
View raw message