forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bowe, Bastian" <Bastian.B...@astrium.eads.net>
Subject RE: Problem getting plugins ...
Date Mon, 21 Feb 2005 09:02:15 GMT
The problem is the <get> task in, I think
$FORREST_HOME/main/targets/plugins.xml or so. You can workaround by going to
$FORREST_HOME/plugins/org.apache.forrest.plugin.pdf-output and running "ant
local-deploy".

Regards

Bastian

> -----Original Message-----
> From: Cyriaque Dupoirieux [mailto:Cyriaque.Dupoirieux@pcotech.fr] 
> Sent: Monday, February 21, 2005 9:58 AM
> To: Liste forrest
> Subject: Problem getting plugins ...
> 
> 
> Hi,
> 
> (Maybe I should send this mail to the dev list ?)
> 
> I have the following error when I run forrest run under docs-author :
> --------------------------------------------------------------
> ----------
> 
> Installing plugin: org.apache.forrest.plugin.pdf-output
> 
> fetch-plugins-descriptors:
> fetching descriptor: http://forrest.apache.org/plugins/plugins.xml
> Getting: http://forrest.apache.org/plugins/plugins.xml
> Error getting http://forrest.apache.org/plugins/plugins.xml to 
> D:\duc\forrest\DOCS-A~1\build\tmp\plugins-1.xml
> 
>             WARNING
>             =======
> 
>             Unable to load plugin list number 1.
>             Any plugins identified in this plugin list cannot 
> be installed
>             automatially, you will need to install these manually, see
>             further errors below.
> 
> unpack-plugin:
> 
> ERROR
> =====
> 
> Unable to retrive the org.apache.forrest.plugin.pdf-output 
> plugin. There may be more information about the reason for 
> this in ouput above. The usual cause is that Forrest has been 
> unable to download the plugin descriptor file that indicates 
> where this plugin is to be downloaded from. Please check the 
> value of the forrest.plugins.descriptors property in the 
> forrest.properties file and ensure that the locations 
> indicated by that value are accessible (note there should be 
> no spaces in this property).
> --------------------------------------------------------------
> ----------
> 
> It works correctly at home under Linux.
> I think the problem comes from my proxy.
> How can I configure the use of a proxy in forrest ?
> 
> -- 
> 
> Regards,
> Cyriaque,
> 

Mime
View raw message