forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sjur Moshagen <sju...@mac.com>
Subject Re: Wiki and UTF-8/non-latin-1
Date Mon, 14 Feb 2005 11:21:08 GMT
På 13. feb. 2005 kl. 16.58 skrev Sjur Moshagen:

> Hello,
>
> I'm trying out the jspwiki input plug-in, and it works out pretty well 
> (=as documented). The only thing is that UTF-8 input is treated as 
> Latin-1.
>
> Is there any way of changing the default encoding for the wiki 
> plug-in, or to specify the encoding in the wiki file?

I found the following information at 
<http://chaperon.sourceforge.net/using-cocoon.html>:

> Optional you can use a parameter to specify the encoding, which should 
>  be used.
>
> <map:transformer name="lexer"
>                  
> src="org.apache.cocoon.transformation.LexicalTransformer"
>                  logger="sitemap.transformer.lexicaltransformer">
>  <map.parameter name="encoding" value="ISO-8851_1"/>
> <map:transformer>

which is also refound in the wiki plugin xmap in forrest 
$FORREST_HOME/plugins/wiki/input.xmap (without the encoding parameter; 
I have not been able to find any documentation on the default encoding 
for the chaperon lexer/parser, but obviously it is Latin-1):

> <map:transformer name="lexer"
>                        
> src="org.apache.cocoon.transformation.LexicalTransformer"
>                        logger="sitemap.transformer.lexer">
>         <parameter name="localizable" value="true"/>
> </map:transformer>

There are two things to note:

- the parameter has no namespace
- the encoding parameter does not work, with or without namespace 
(map:). I used:

<map:parameter name="encoding" value="UTF-8"/>

but my UTF-8 wiki document is still read as Latin-1.

Is this a Forrest bug? A Chaperon Bug? A Cocoon bug? Am I missing 
something?

Any help appreciated!

Regards,
Sjur


Mime
View raw message