forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stefan Baramov" <Stefan.Bara...@trx.com>
Subject XSP page useage
Date Thu, 03 Feb 2005 21:31:55 GMT
I followed the instructions at http://forrest.apache.org/faq.html#xsp to
activate the XSP support. However, when I build my project I get : 

     [java] Line 0, column 0: This compilation unit indirectly
references the missing type org.apache.cocoon.caching.Cacheable
(typically some required class file is referencing a type outside the
classpath)


My XSP is the Hello page from from Cocoon 2.1.6: 

<xsp:page language="java"
          xmlns:xsp="http://apache.org/xsp">

  <page>
    <title>Hello</title>
    <content>
      <para>This is my first Cocoon page!</para>

      <xsp:element name="para">
        With the help of XSP and 
        <xsp:expr>Constants.COMPLETE_NAME</xsp:expr>
      </xsp:element>
    </content>
  </page>

</xsp:page>



The following pipeline is defined in sitemap.xmap:

    <map:pipeline>
      <map:match pattern="install*">
        <map:generate src="{project:content.xdocs}/install.xsp"
type="serverpages"/>
        <map:serialize type="xml"/>
      </map:match>
    </map:pipeline>

Plus a generator: 
      <map:generator name="serverpages" pool-grow="2" pool-max="32"
pool-min="4" 
        src="org.apache.cocoon.generation.ServerPagesGenerator"/>


The page is reference in site.xml by this line: 
	<download label="Installation" href="install.xsp"/>


I am using Forrest 0.6

So, what is wrong ? 

Thanks
Stefan Baramov 

Mime
View raw message