forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Greg Yenchi" <greg.v...@cox.net>
Subject RE: Forrest crashes without an xdoc/index.xml file
Date Thu, 20 Jan 2005 19:11:45 GMT
Ross --

I still get the SourceExecption after I cleaned up all of the broken link
messages, except for the one "cocoon://index.html", which I cannot find the
source for.  I actually had this problem in my own Forrest site where I know
that I have no broken links, but I re-produced it in fresh-site just to make
sure it wasn't caused by my other modifications.  Plus, I'm getting the Java
exception trace, not just the standard broken link message.

-- Greg

-----Original Message-----
From: Ross Gardler [mailto:rgardler@apache.org] 
Sent: Wednesday, January 19, 2005 11:08 AM
To: user@forrest.apache.org
Subject: Re: Forrest crashes without an xdoc/index.xml file

greg.vaco@cox.net wrote:
> Forrest (Head, revision 125624) seems to assume there's an index.xml file
in the xdoc root directory.  Without this file, Forrest throws a nasty
exception shown below; however, the site seems to render correctly.  To
reproduce this error, seed a fresh project, rename index.xml, and then
update site.xml & tab.xml accordingly.
> 
> An easy workaround is to include a dummy index.xml file, which stops the
exception.  But, I'm not sure if there's some undiscovered side-effect.  Can
anyone shed any light on this problem?

I don't think this is a bug. There are other links to index.html in the 
fresh-site and so Forrest is trying to render it (see 
samples/usemap.xml). I have not tested it, perhaps you could do that for 
me, but if you change *all* references to index.* in fresh-site then 
this should go away.

To see what pages are linking to the missing file look at 
project_home/build/tmp/brokenlinks.xml

Ross



-- 
No virus found in this outgoing message.
Checked by AVG Anti-Virus.
Version: 7.0.300 / Virus Database: 265.7.0 - Release Date: 17/01/2005



Mime
View raw message