forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Brondsema <d...@brondsema.net>
Subject Re: Forrest crashes without an xdoc/index.xml file
Date Fri, 21 Jan 2005 18:56:10 GMT
Quoting Ross Gardler <rgardler@apache.org>:

> 
> 
> Greg Yenchi wrote:
> > Ross --
> > 
> > I still get the SourceExecption after I cleaned up all of the broken link
> > messages, except for the one "cocoon://index.html", which I cannot find
> the
> > source for.  I actually had this problem in my own Forrest site where I
> know
> > that I have no broken links, but I re-produced it in fresh-site just to
> make
> > sure it wasn't caused by my other modifications.  Plus, I'm getting the
> Java
> > exception trace, not just the standard broken link message.
> 
> Thanks for taking the time to investigate, it seems you have unearthed a 
> bug.
> 
> Please open an issue for us and link back to this thread for 
> completeness, we'll take a look at the cause soon (I suspect it is 
> something to do with the link crawler).

Are there any references (in links, site.xml or tabs.xml) to "foldername/"?  The
cocoon link crawler will use index.html as the default index file for that
directory.  That is configured (IIRC) in cli.xconf, which is overridable by the
project.


-- 
Dave Brondsema : dave@brondsema.net 
http://www.brondsema.net : personal 
http://www.splike.com : programming 
http://csx.calvin.edu : student org 

Mime
View raw message