forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ross Gardler <rgard...@apache.org>
Subject Re: Trouble with OpenOffice plugin
Date Sat, 04 Dec 2004 17:00:42 GMT
Charles Palmer wrote:
> 1    You asked "Does it say that the plugin is successfully installed?" -
> that is the earlier OpenOffice.org plugin - no, it didn't say it succeeded,
> but it didn't say it failed either. There were 3 lines about loading
> properties before it moved onto the next plugin (pdf-output).

You will always get a message saying it succedded if it succeeded. 
Likewise you will get an error like that below if it fails.

> 2    I changed the entry in forrest.properties to
> "org.apache.forrest.plugins.OpenOffice.org" but that failed because it
> should be "..plugin..." without the "s". The error messages were not very
> helpful:

Yes, error messages need improvement.

> 3    I changed the entry in forrest.properties to
> "org.apache.forrest.plugin.OpenOffice.org" and tied again.

(sorry about the typo my last message)

> This time it
> failed again with a bunch of error messages, ending with this one:
> D:\junk\tt\build\tmp\pluginlist2fetchbuild.xml:16: Unable to download the
>               "org.apache.forrest.plugin.OpenOffice.org" plugin from
>               http://forrest.apache.org/plugins/.
>               In case the reason is the network connection, you can try
>               installing the package manually by placing the file in the
>               plugins directory.

Looking at your attached log we see the failure:

Error getting 
http://forrest.apache.org/plugins/org.apache.forrest.plugin.OpenOf
fice.org.zip to 
D:\Forrest_Dec_04\forrest\build\plugins\org.apache.forrest.plugi
n.OpenOffice.org.zip

However, if you look at the URL it is trying to download 
(http://forrest.apache.org/plugins/org.apache.forrest.plugin.OpenOf
fice.org.zip ) you will see the file does exist. So have you any idea 
why your Forrest couldn't download over your network? Are you behind a 
firewall?

It may just be you are working with a snapshot. Plugins are *very* new 
and so they are changing rapidly at the moment. If you really want to 
work with the latest and greatest you really should work with SVN head.

> Though I did end up with a file called forrest_20041201171246.tar.gz in my
> FORREST_HOME directory.

This is nothing to do with the plugins download. This looks like a 
snapshot tar file.

> 4    So I downloaded org.apache.forrest.plugin.OpenOffice.org.zip from
> http://forrest.apache.org/plugins/OpenOffice.org, unzipped it and installed
> it here:
> D:\Forrest_Dec_04\forrest\plugins\org.apache.forrest.plugin.OpenOffice.org
> (which seemd to be the right place for it!) and tried again. This time it
> worked (yay!), although, despite the fact that I had manually downloaded the
> plugin and installed it, it looks like Forrest went off your the Forrest
> website and looked for various files - sometime unsuccessfully. (Maybe so
> other file had to be updated to let Forrest know I had downloaded a new
> plugin?

You placed the plugin in the src directory. Forrest does not work with 
it in that location (yet). To locally deploy a plugin so you can run 
Forrest with it going to the network do an /ant local-deploy/ inside the 
plugin directory (you need to be using the version of ANT that comes 
with Forrest).

> 5    To check that the samples included in the OOo plugin worked (as well as
> my trivial one-line .sxw file) and to see whether Forrest went off to the
> website again, I added the samples to my samples folder and modified
> site.xml and tried again. Success! Everything built fine and there were no
> further accesses to the website.

OK, so at some point Forrest successfully downloaded the plugin and 
installed it. You mention above that "Forrest went off your the Forrest
  website and looked for various files - sometime unsuccessfully". 
Forrest will sometimes be unsuccessful as it looks for a version copy of 
the plugin first. If it does not exist it looks for an unversioned copy 
so you will see a filed attempt to get the versioned copy followed by a 
successful attempt to get the unversioned.

> So well done guys - it seems to work but there are a few rough edges still.

Thanks for helping us identify the rough edges ;-)

> Maybe the documentation could be updated, since this page
> http://forrest.apache.org/docs/plugins.html#What+plugins+are+available%3F
> still talks about the earlier name for the plugin, and refers to
> "forrestcore/src/core/context/default.forrest.properties ", which no longer
> seems to exist.

Missed that one, I'll update thanks.

> Perhaps add a few words, too, about where plugins end up: I had manually
> unzipped the plugin here:
> D:\Forrest_Dec_04\forrest\plugins\org.apache.forrest.plugin.OpenOffice.org
> since it seemed the right place, but I have just discovered that the
> automatic installation process seems to have created the plugin here:
> D:\Forrest_Dec_04\forrest\build\plugins\org.apache.forrest.plugin.OpenOffice
> .org

I don't think I will do that as the plugins directory is only of use to 
developers and the above document is a user document (you count as a 
developer since you are using SVN head). However, some clarification in 
the message that says "try manually installing" would be useful.

Thank you for taking the time to give us your feedback, it is very valuable.

Ross

Mime
View raw message