forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Charles Palmer" <>
Subject Re: Trouble with OpenOffice plugin
Date Sat, 04 Dec 2004 15:56:43 GMT
Hi Ross

Thanks for your help. I tried several times and eventually succeeded. In
case my history is of any help to others I'll tell you what I did:

1    You asked "Does it say that the plugin is successfully installed?" -
that is the earlier plugin - no, it didn't say it succeeded,
but it didn't say it failed either. There were 3 lines about loading
properties before it moved onto the next plugin (pdf-output).

2    I changed the entry in to
"" but that failed because it
should be "..plugin..." without the "s". The error messages were not very

Trying to get "" plugin version

D:\Forrest_Dec_04\forrest\main\targets\plugins.xml:196: The following error
rred while executing this line:
D:\Forrest_Dec_04\forrest\main\targets\plugins.xml:199: The following error
rred while executing this line:
D:\Forrest_Dec_04\forrest\main\targets\plugins.xml:159: The following error
rred while executing this line:
D:\Forrest_Dec_04\forrest\main\targets\plugins.xml:172: The following error
rred while executing this line:
: no protocol:

3    I changed the entry in to
"" and tied again. This time it
failed again with a bunch of error messages, ending with this one:
D:\junk\tt\build\tmp\pluginlist2fetchbuild.xml:16: Unable to download the
              "" plugin from
              In case the reason is the network connection, you can try
              installing the package manually by placing the file in the
              plugins directory.

Though I did end up with a file called forrest_20041201171246.tar.gz in my
FORREST_HOME directory.

4    So I downloaded from, unzipped it and installed
it here:
(which seemd to be the right place for it!) and tried again. This time it
worked (yay!), although, despite the fact that I had manually downloaded the
plugin and installed it, it looks like Forrest went off your the Forrest
website and looked for various files - sometime unsuccessfully. (Maybe so
other file had to be updated to let Forrest know I had downloaded a new
plugin? Or maybe I put it in the wrong place - see below). I attach the
messages in a file in case a post-mortem is of any use to anyone

5    To check that the samples included in the OOo plugin worked (as well as
my trivial one-line .sxw file) and to see whether Forrest went off to the
website again, I added the samples to my samples folder and modified
site.xml and tried again. Success! Everything built fine and there were no
further accesses to the website.

So well done guys - it seems to work but there are a few rough edges still.
Maybe the documentation could be updated, since this page
still talks about the earlier name for the plugin, and refers to
"forrestcore/src/core/context/ ", which no longer
seems to exist.

Perhaps add a few words, too, about where plugins end up: I had manually
unzipped the plugin here:
since it seemed the right place, but I have just discovered that the
automatic installation process seems to have created the plugin here:

Now, on with the serious business of using it...

Charles Palmer

----- Original Message -----
From: "Ross Gardler" <>
To: <>
Sent: Saturday, December 04, 2004 1:50 AM
Subject: Re: Trouble with OpenOffice plugin

> Ross Gardler wrote:
> > Charles Palmer wrote:
> >
> >> I've downloaded a snapshot (1 December) and built the standard files
> >> OK. I've added a simple OOo file (called openoffice-writer2.sxw) into
> >> the samples folder and a matching entry to site.xml, added
> >> to, and
> >> re-run forrest.
> I just completed some work on the plugin. It shouldn't
> affect your work, but you never know. The major change is that the
> plugin now supports embedded images in the Open Office documents.
> However, the significant change for you is that the plugin name has
> changed (we now have a naming convention).
> The new name is, I'd recomend
> switching to that plugin.
> However, the old plugin (under than name of is still
> available and should work.
> Ross

View raw message