forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sjur Nørstebø Moshagen <sju...@mac.com>
Subject Re: Plugin downloading problems
Date Wed, 24 Nov 2004 12:04:40 GMT
På 24. nov. 2004 kl. 13.06 skrev Ross Gardler:

> Now fixed - thanks for highlighting this

Thanx for fixing it so fast!

>> - not having a project.required.plugins should be equal to an empty  
>> list (why is simplified-docbook suddenly required when the plugins  
>> property is commented out?)
>
> This is to maintain backward compatability with 0.6 simplified-docbook 
> (and some other plugins) are extracted from the core of 0.6. There are 
> many sites that use these features and so, at least for now, we have 
> made it default that in the absence of instructions otherwise they are 
> included.

Ok.

> However, if you do a forrest seed from 0.7-dev you will not have these 
> defaults.

Well, that was exactly what I did:

svn up
forrest seed
#forrest.required.plugins
forrest run - bang!

It won't bang now since you fixed the downloading issue, so I guess 
this isn't really a topic anymore (but it would be nice to document the 
default behaviour, nothing is mentioned at 
http://forrest.apache.org/docs/plugins.html).

Sjur


Mime
View raw message