forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Howard Lewis Ship <hls...@gmail.com>
Subject [RESOLUTION] Upgrade to 0.6: validation issues
Date Tue, 26 Oct 2004 13:59:55 GMT
I eventually did get the HiveMind site building properly, but it took
a LOT of effort.

I've documented my experiences on my blog:

http://howardlewisship.com/blog/2004/10/upgraded-hivemind-to-forrest-06.html

Results are visible online:

http://jakarta.apache.org/hivemind/

There's definately a bug afoot where the system thinks all
"index.html" files are exactly the same, regardless of the folder!


On Thu, 21 Oct 2004 09:21:35 -0700, Clay Leeds <cleeds@medata.com> wrote:
> On Oct 21, 2004, at 7:23 AM, Howard Lewis Ship wrote:
> > I'm getting closer, but still no dice.
> >
> > The HiveMind site is multiple levels; it has subdirectories for each
> > module.
> >
> > What I'm seeing is that the index.html in the subdirectories ends up
> > with the exact same content (that is, byte-for-byte the same file) as
> > the root index.html.  Not only is the content wrong, but the relative
> > URLs are broken (to the skin directory, to pick up images and
> > stylesheets).
> >
> > I actually re-ran the build using Forrest command line:
> >
> > C:\workspace\jakarta-hivemind>forrest
> 
> [..]
> 
> > X [0]                                     wholesite.html
> > BROKEN: java.lang.RuntimeException:
> > org.apache.cocoon.ResourceNotFoundException: Resource not found.:
> > org.apach
> > e.excalibur.source.SourceNotFoundException:
> 
> I would recommend you turn off the 'wholesite.html' until this issue is
> resolved.
> 
> > file:/C:/workspace/jakarta-hivemind/target/forrest-composite/content/
> > xdocs/HiveMind-QuickReference.xml
> > doesn't exist.
> 
> [..]
> 
> > X [0]                                     wholesite.pdf BROKEN:
> > org.apache.fop.apps.FOPException: No flow in page-sequence
> 
> and turn off wholesite.pdf too.
> 
> [..]
> 
> > BUILD FAILED
> > C:\workspace\jakarta-hivemind\ext-package\apache-forrest
> > -0.6\src\core\targets\site.xml:43:
> > Java returned: 1
> >
> > Total time: 1 minute 0 seconds
> >
> > C:\workspace\jakarta-hivemind>
> >
> > I see that the forrest docs split out across multiple folders, so I
> > can't figure out what my be different in my environment.
> >
> > This only affects the index.html in each sub-directory.  The other
> > files in each sub-directory come out correctly.
> >
> > Can you think of what might cause a problem like this?  It's as if
> > Cocoon was saying "index.html? that looks familiar, I'll just write
> > out the one I just rendered" ... and its ignoring the fact that its a
> > different directory.
> 
> This is indeed strange, and I don't know what would cause this. Perhaps
> they all have the same 'id' in site.xml or something silly like that.
> 
> Web Maestro Clay
> --
> Clay Leeds - <cleeds@medata.com>
> Webmaster/Developer - Medata, Inc. - <http://www.medata.com/>
> PGP Public Key: <https://mail.medata.com/pgp/cleeds.asc>
> 
> 


-- 
Howard M. Lewis Ship
Independent J2EE / Open-Source Java Consultant
Creator, Jakarta Tapestry
Creator, Jakarta HiveMind
http://howardlewisship.com

Mime
View raw message