forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Clay Leeds <cle...@medata.com>
Subject Re: Broken linkmap
Date Fri, 29 Oct 2004 18:01:45 GMT
On Oct 29, 2004, at 10:21 AM, Ross Gardler wrote:
> Clay Leeds wrote:
>> On Oct 29, 2004, at 6:49 AM, Ross Gardler wrote:
>>> Clay Leeds wrote:
>>
>> I just deleted forrestcore/plugins/sitemap.xmap and ran /forrest/:
>> X [0]                                     linkmap.html  BROKEN: No   
>> pipeline matched request: linkmap-linkmap.html
>> Total time: 0 minutes 22 seconds,  Site size: 0 Site pages: 0
>> BUILD FAILED
>> /Users/Shared/_WebDLs/_repos/forrest/forrestcore/src/core/targets/  
>> site.xml:43: Java returned: 1
>> Total time: 41 seconds
>> [clay@Clay-Leeds-Computer medata_docs]$
>> so I'm assuming it's with the plugins...
>
> No this means it is *not* the plugins since none of them are being  
> loaded.

<snip>

>>> If you have an application that worked in 0.6 you can still use   
>>> 0.7-dev with no changes to your forrest.properties file since the   
>>> default behaviour is to include all plugins that contain  
>>> functionality  extracted from the 0.6 release. In other words the  
>>> developer need do  nothing unless they want to use new functionality  
>>> provided by new  plugins.
>> That would be true, except in my case all of my files are   
>> OpenOffice.org files...
>
> No, you misunderstand. If you don't add a project.required.plugins  
> property it will *automatically* load the simplified-Docbook and  
> OpenOffice.org plugins. You don't have to do anything if you want to  
> maintain compatability with 0.6.
>
> (I've clarified this in the docs in SVN alread)

OK... That is good to know. Oh what a a tangled web we weave...

>> BUILD FAILED
>> /Users/Shared/_WebDLs/_repos/forrest/forrestcore/src/core/targets/  
>> plugins.xml:128: The following error occurred while executing this   
>> line:
>> /Users/Shared/_WebDLs/_repos/forrest/forrestcore/src/core/targets/  
>> plugins.xml:131: The following error occurred while executing this   
>> line:
>> /Users/Shared/_WebDLs/_repos/forrest/forrestcore/src/core/targets/  
>> plugins.xml:107: The following error occurred while executing this   
>> line:
>> /Users/Shared/_WebDLs/_repos/forrest/forrestcore/src/core/targets/  
>> plugins.xml:120: The following error occurred while executing this   
>> line:
>> /Users/Shared/_WebDLs/_repos/medata_docs/build/tmp/  
>> pluginlist2fetchbuild.xml:7: java.net.MalformedURLException: no   
>> protocol: simplified-docbook-${version}.zip
>
> As mentioned in another post, this is fixed. This was caused by a  
> glitch in the site updating process that meant a change in SVN was not  
> reflected on the published site. Result was that an old version of  
> plugins.xml was published. This won't happen again as the glitch has  
> been removed.

Just ran again, after commenting out the project.required.plugins  
entry. Still "D'oh!".

X [0]                                     linkmap.html  BROKEN: No  
pipeline matched request: linkmap-linkmap.html
Total time: 0 minutes 19 seconds,  Site size: 0 Site pages: 0

BUILD FAILED
/Users/Shared/_WebDLs/_repos/forrest/forrestcore/src/core/targets/ 
site.xml:43: Java returned: 1

Total time: 40 seconds
[clay@Clay-Leeds-Computer medata_docs]$

> Now that we have that out of the way lets return to your linkmap  
> problem. Can you confirm that when you run without plugins enabled  
> (deleting forrestcore/plugins/sitemap.xmap) you still get the same  
> problem.

Running now... (twiddling for 36-40 seconds...) and... drumroll  
please... "D'oh!"

X [0]                                     linkmap.html  BROKEN: No  
pipeline matched request: linkmap-linkmap.html
Total time: 0 minutes 19 seconds,  Site size: 0 Site pages: 0

BUILD FAILED
/Users/Shared/_WebDLs/_repos/forrest/forrestcore/src/core/targets/ 
site.xml:43: Java returned: 1

Total time: 38 seconds
[clay@Clay-Leeds-Computer medata_docs]$

> If you do then it is nothing to do with the plugins, it is something  
> else causing it.
>
>> Funny thing is, I'm not using anything besides OpenOffice.org files,  
>> so  why is it complaining about simplified-docbook? For that matter,  
>> why  does it download IMSManifest?
>
> Does the above autoloading explanation make sense now?
>
> Ross

Makes sense! (Still "D'oh!" ;-)) Glad I have 'help'!

Web Maestro Clay
-- 
Clay Leeds - <cleeds@medata.com>
Webmaster/Developer - Medata, Inc. - <http://www.medata.com/>
PGP Public Key: <https://mail.medata.com/pgp/cleeds.asc>


Mime
View raw message