forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ross Gardler <rgard...@apache.org>
Subject Re: Broken linkmap
Date Fri, 29 Oct 2004 13:49:09 GMT
Clay Leeds wrote:
> On Oct 28, 2004, at 9:37 PM, David Crossley wrote:
> 
>> Clay Leeds wrote:
>>
>>> On Oct 28, 2004, at 6:34 PM, Ross Gardler wrote:
>>>
>>>> This will only have affected people working with SVN head. However,  it
>>>> is now fixed, please do an svn up and you should be working fine.
>>>>
>>>> Ross
>>>
>>>
>>> I have done an /svn up/ and I still get:
>>> ---------------------------------------------------------------------- 
>>> -- 
>>> X [0]                                     linkmap.html  BROKEN: No
>>> pipeline matched request: linkmap-linkmap.html
>>> Total time: 0 minutes 30 seconds,  Site size: 0 Site pages: 0
>>
>>
> 

<snip/>

> 
> Whole site capability was still in there. I disabled it, and I still  get:
> 
> ====
> X [0]                                     linkmap.html  BROKEN: No  
> pipeline matched request: linkmap-linkmap.html
> Total time: 0 minutes 18 seconds,  Site size: 0 Site pages: 0
> 
> BUILD FAILED
> /Users/Shared/_WebDLs/_repos/forrest/forrestcore/src/core/targets/ 
> site.xml:43: Java returned: 1
> 
> Total time: 37 seconds
> ====

Do you have a project sitemap? It may be that that is causing the 
problem. You can test this by deleting the 
forrestcore/plugins/sitemap.xmap file. This will prevent Forrest from 
using any plugins. If there error goes away then the problem is with 
your projects sitemap.xmap, if it doesn't it is with the plugins. Let me 
know which way around it is.

[NB, in once this test is done you will need to delete the whole 
forrestcore/plugins directory and rebuild Forrest to re-enable the 
plugins functionality]

> One thing I should mention (and this is almost certainly related to the  
> problem :-)) is that this site consists almost exclusively of  
> OpenOffice.org sxw files (except for the 'index.html' pages), and I  
> have not done anything to configure the plugins yet (other than /svn  
> up/ I have not installed any plugins). 

I don't think this is related since the error has nothing to do with 
openOffice documents.

> I'm still a bit unclear on how  
> to do that (I'll dig through my ML archives for clues...). 

I'd recommend reading the docs, it's more efficient ;-). see "How to 
install plugins" - 
http://forrest.apache.org/docs/plugins.html#How+is+a+Plugin+Installed%3F

Since it is only two lines (and the other job I have this morning is 
building furniture), I'll be nice and copy the relevant bit here:

"If a site requires a plugin then it will be named in the 
project.required.plugins property in the projects forrest.properties 
file. When Forrest builds the site it will automatically discover the 
plugin and install it. In other words, the user need do nothing."

(not in the docs, but relevant - so I'll put in the docs now)

If you have an application that worked in 0.6 you can still use 0.7-dev 
with no changes to your forrest.properties file since the default 
behaviour is to include all plugins that contain functionality extracted 
from the 0.6 release. In other words the developer need do nothing 
unless they want to use new functionality provided by new plugins.

[NB if you delete the plugins directory as described above, rebuild 
forrest and do a forrest run (or site) you should see in the output that 
Forrest is downloading and installing the required plugins]

>If that is  
> the problem (missing OOo plugin), it may make sense to create some sort  
> of error which indicates such (something like "No plugin was found  
> which supports the '*.sxw' format needed to process file  'yatayata.sxw'").

If for any reason the plugin was not available Cocoon would complain 
about no match found for yatayata.sxw.

Ross

Mime
View raw message