forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stephan E. Schlierf" <stephan.schli...@vsa.de>
Subject Re: Forrest 0.6: No PNGs in pdf-files
Date Fri, 22 Oct 2004 13:09:49 GMT
Am Freitag, 22. Oktober 2004 14:35 schrieb Juan Jose Pablos:
> Stephan E. Schlierf wrote:
> > Am Freitag, 22. Oktober 2004 13:25 schrieb Juan Jose Pablos:
> >>Stephan E. Schlierf wrote:
> >>>>>Whta I did first was:
> >>>>>Copied jimi-1.0.jar into $FORREST_HOME/lib/optional
> >>>>>Rebuilt Forrest
> >>>>>No succes
> >>>>
> >>>>With that change it should work.
> >>>
> >>>Sorry, no, it doesn't work.
> >>
> >>Could you check if the @src has a .. within?
> >>ie src="../images/icon.png"
> >>
> >>I have just found out that "forrest site" does link property images with
> >>a .. in it.
> >
> > Hm, this causes a "broken link" exception during a "forrest site".
>
> Sorry I wanted to said that it does not work. I think that this is the
> error on the logs:
>
> WARN    (2004-10-22) 13:22.01:989   [core.manager] (/images/group.png)
> PoolThrea
> d-3/SVGBuilder: setDocumentLocator was not called, will use
> http://localhost/ as
>   base URI
>
> > The structure on my hard disk is:
> >
> > myfile.xml
> > images/
> >  myFirstImage.png
> >  mySecondImage.png
> >
> > It's just the structure of the project that a "forrest seed" generates.
>
> It seems that this is the issue.
>
> Cheers,
> Cheche

o.k., here we are:
The logfile says:

debug.log:ERROR   (2004-10-22) 14:13.32:252   [debug.manager.fop] 
(Unknown-URI) Unknown-thread/ExternalGraphic: Error while creating area : 
Error with image 
URL: /home/stephan/ForrestTest/src/documentation/resources/images/mda_ansatz.png 
(No such file or directory) and no base URL is specified

So the problem is that I placed my png-files in 
src/domentation/content/xdocs/images/
and fop expects them in
src/documentation/resources/images/
At least, after moving them to src/documentation/resources/images/ they are 
correctly displayed in a pdf-file.

I was a little bit confused: I thought I should place my images in that 
directory where the images are located after a "forrest seed".

Thanks for your help, Cheche :-)

Stephan

Mime
View raw message